
<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
  <head>
    <meta charset="utf-8" /><script type="text/javascript">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</script>
<script>
(function(w, d) {
w.adthrive = w.adthrive || {};
w.adthrive.cmd = w.adthrive.cmd || [];
w.adthrive.plugin = 'adthrive-ads-1.0.43-manual';
w.adthrive.host = 'ads.adthrive.com';
var s = d.createElement('script');
s.async = true;
s.referrerpolicy='no-referrer-when-downgrade';
s.src = 'https://' + w.adthrive.host + '/sites/5e6a20e38517f75513c5c032/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href);
var n = d.getElementsByTagName('script')[0];
n.parentNode.insertBefore(s, n);
})(window, document);</script>
<script>
window.dataLayer = window.dataLayer || [];
dataLayer.push({
    "bpm_template": "content-all",
    "vn_template": "content-all",
    "bpm_post_id": "641450",
    "bpm_publish_date": "2022_03_14",
    "bpm_content_type": "bpm-editorial-news-quick",
    "bpm_primary_category": "phones",
    "bpm_cat_list": "android,phones",
    "bpm_tag_list": "samsung,news,samsung galaxy a53,samsung galaxy a73",
    "vn_content_type": "flash news",
    "vn_network_category": "tech",
    "vn_intent": "short-term"
});
        </script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&amp;l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-M4DZGGG');</script>
<meta name="parsely-title" content="Samsung to announce next Galaxy A series smartphones on March 17" />
<meta name="parsely-link" content="https://pocketnow.com/samsung-galaxy-a-march-17-event-announced" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://media.pocketnow.com/styles/large/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=BnZe5YQf" />
<meta name="parsely-pub-date" content="2022-03-14T01:30:50-04:00" />
<meta name="parsely-section" content="Phones" />
<meta name="parsely-author" content="Sanuj Bhatia" />
<meta name="parsely-tags" content="Android,Samsung,News,Samsung Galaxy A53,Samsung Galaxy A73" />
<meta name="og:url" content="https://pocketnow.com/samsung-galaxy-a-march-17-event-announced" />
<meta name="og:type" content="article" />
<meta name="og:title" content="Samsung to announce next Galaxy A series smartphones on March 17" />
<meta name="og:description" content="Samsung has announced that it will be announcing its new Galaxy A series smartphones later this week on March 17. Learn more about the event and how you can watch here." />
<meta name="og:image" content="https://media.pocketnow.com/styles/large/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=BnZe5YQf" />
<meta name="twitter:site" content="@pocketnow" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Samsung to announce next Galaxy A series smartphones on March 17" />
<meta name="twitter:description" content="Samsung has announced that it will be announcing its new Galaxy A series smartphones later this week on March 17. Learn more about the event and how you can watch here." />
<meta name="twitter:image" content="https://media.pocketnow.com/styles/large/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=BnZe5YQf" />
<script type="application/ld+json">{
    "@context": "http:\/\/schema.org",
    "@graph": [
        {
            "@type": [
                "NewsArticle",
                "Article"
            ],
            "@id": "https:\/\/pocketnow.com\/samsung-galaxy-a-march-17-event-announced#article",
            "isPartOf": {
                "@id": "https:\/\/pocketnow.com\/samsung-galaxy-a-march-17-event-announced#webpage"
            },
            "author": {
                "@id": "https:\/\/pocketnow.com\/author\/sanuj"
            },
            "creator": {
                "@id": "https:\/\/pocketnow.com\/author\/sanuj"
            },
            "headline": "Samsung to announce next Galaxy A series smartphones on March 17",
            "dateCreated": "2022-03-14T01:30:50-04:00",
            "datePublished": "2022-03-14T01:30:50-04:00",
            "dateModified": "2022-03-14T01:30:50-04:00",
            "mainEntityOfPage": {
                "@id": "https:\/\/pocketnow.com\/samsung-galaxy-a-march-17-event-announced#webpage"
            },
            "publisher": {
                "@id": "https:\/\/pocketnow.com\/#organization"
            },
            "image": {
                "@id": "https:\/\/media.pocketnow.com\/styles\/large\/public\/2022-03\/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=BnZe5YQf#primaryimage"
            },
            "articleSection": "Phones",
            "keywords": [
                "Android",
                "Samsung",
                "News",
                "Samsung Galaxy A53",
                "Samsung Galaxy A73"
            ],
            "inLanguage": "en-US"
        },
        {
            "@type": "Person",
            "@id": "https:\/\/pocketnow.com\/author\/sanuj",
            "name": "Sanuj Bhatia",
            "url": "https:\/\/pocketnow.com\/author\/sanuj"
        },
        {
            "@type": "Organization",
            "@id": "https:\/\/pocketnow.com\/#organization",
            "name": "Pocketnow",
            "url": "https:\/\/pocketnow.com\/",
            "logo": {
                "@id": "https:\/\/pocketnow.com\/#logo"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https:\/\/pocketnow.com\/#website",
            "url": "https:\/\/pocketnow.com\/",
            "name": "Pocketnow",
            "description": "",
            "publisher": {
                "@id": "https:\/\/pocketnow.com\/#organization"
            },
            "inLanguage": "en-US"
        },
        {
            "@type": "ImageObject",
            "@id": "https:\/\/media.pocketnow.com\/styles\/large\/public\/2022-03\/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=BnZe5YQf#primaryimage",
            "inLanguage": "en-US",
            "url": "https:\/\/media.pocketnow.com\/styles\/large\/public\/2022-03\/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=BnZe5YQf"
        },
        {
            "@type": "ImageObject",
            "@id": "https:\/\/pocketnow.com\/#logo",
            "inLanguage": "en-US",
            "url": "https:\/\/pocketnow.com\/sites\/pocketnow\/logos\/logo.png"
        },
        {
            "@type": "WebPage",
            "@id": "https:\/\/pocketnow.com\/samsung-galaxy-a-march-17-event-announced#webpage",
            "url": "https:\/\/pocketnow.com\/samsung-galaxy-a-march-17-event-announced",
            "name": "Samsung to announce next Galaxy A series smartphones on March 17",
            "isPartOf": {
                "@id": "https:\/\/pocketnow.com\/#website"
            },
            "primaryImageOfPage": {
                "@id": "https:\/\/media.pocketnow.com\/styles\/large\/public\/2022-03\/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=BnZe5YQf#primaryimage"
            },
            "datePublished": "2022-03-14T01:30:50-04:00",
            "dateModified": "2022-03-14T01:30:50-04:00",
            "description": "Samsung has announced that it will be announcing its new Galaxy A series smartphones later this week on March 17. Learn more about the event and how you can watch here.",
            "inLanguage": "en-US"
        }
    ]
}</script>
<meta name="robots" content="max-image-preview:large" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="description" content="Samsung has announced that it will be announcing its new Galaxy A series smartphones later this week on March 17. Learn more about the event and how you can watch here." />
<link rel="apple-touch-icon" sizes="180x180" href="/sites/pocketnow/icons/apple-touch-icon.png" />
<link rel="apple-touch-icon" sizes="167x167" href="/sites/pocketnow/icons/apple-touch-icon-167x167-precomposed.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/sites/pocketnow/icons/apple-touch-icon-152x152-precomposed.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/sites/pocketnow/icons/apple-touch-icon-120x120-precomposed.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/sites/pocketnow/icons/apple-touch-icon-72x72-precomposed.png" />
<link rel="apple-touch-icon" sizes="57x57" href="/sites/pocketnow/icons/apple-touch-icon-57x57-precomposed.png" />
<link rel="apple-touch-icon" sizes="32x32" href="/sites/pocketnow/icons/favicon-32x32.png" />
<link rel="apple-touch-icon" sizes="16x16" href="/sites/pocketnow/icons/favicon-16x16.png" />
<link rel="manifest" href="/sites/pocketnow/icons/site.webmanifest" />
<link rel="icon" type="image/svg+xml" href="/sites/pocketnow/icons/favicon.svg" />
<link rel="icon" type="image/x-icon" href="/sites/pocketnow/icons/favicon.ico" />
<link rel="mask-icon" color="#246E91" href="/sites/pocketnow/icons/safari-pinned-tab.svg" />
<meta name="msapplication-square70x70logo" content="/sites/pocketnow/icons/mstile-70x70.png" />
<meta name="msapplication-square150x150logo" content="/sites/pocketnow/icons/mstile-150x150.png" />
<meta name="msapplication-wide310x150logo" content="/sites/pocketnow/icons/mstile-310x150.png" />
<meta name="msapplication-square310x310logo" content="/sites/pocketnow/icons/mstile-310x310.png" />
<meta name="msapplication-TileColor" content="#246E91" />
<meta name="theme-color" content="#246E91" />
<link rel="canonical" href="https://pocketnow.com/samsung-galaxy-a-march-17-event-announced" />
<link rel="shortlink" href="https://pocketnow.com/node/641450" />

    <title>Samsung to announce next Galaxy A series smartphones on March 17 - Pocketnow</title>
    <link rel="stylesheet" media="all" href="/sites/pocketnow/files/css/css_GS5y4nGju6FI7Yz94lW6C2xFy7y_oqvW_SsraV0ZPvk.css" />
<link rel="stylesheet" media="all" href="/sites/pocketnow/files/css/css_LawoM3XBgAulKQgw6gYV6kV-3B5aRlH3MKYoafaCkmA.css" />
<link rel="stylesheet" media="all" href="/sites/pocketnow/files/css/css_dNixvwBwhlOrWd4SsMTp3pOe3Bh0vsa91Ue74kONqnQ.css" />
<link rel="stylesheet" media="all" href="/sites/pocketnow/files/css/css_3bPhQEE2iGYvecX850F1QOnb0yPUbskug6xtH0ewwTo.css" />
<link rel="stylesheet" media="all" href="/sites/pocketnow/files/css/css_YA53w5z-copzPX_YAm9D3FCLt-i1C1hCSUZ6xOVdXdo.css" />

    
  </head>
  <body class="page-template-standard path-node page-node-type-article">
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M4DZGGG" width="0" height="0" style="display:none;visibility:hidden"></iframe>
</noscript>

      <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    


<header>
	  <div class="region region-page-header">
    
<div id="block-alertbar" class="block block-block-content block-block-contentb3c3a478-d196-42bc-9613-5e3e64cbe42e">
  
    
      <p><a rel="nofollow noopener noreferrer" target="_blank" href="https://shop-links.co/cgBZ2sLng8K">Get a Samsung Galaxy S22 and save big!!</a></p>
<style>
#block-alertbar {
  background-color: #003ac2;
}
</style>
  </div>
<nav class="navbar" role="navigation">
  <div class="navbar-burger">
    <button>
      <i class="fas fa-bars"></i>
    </button>
    <div class="navbar-burger-menu">
      
              <ul class="menu is-burger">
              <li>
        <a href="/iphone-13" data-drupal-link-system-path="node/633253">Apple iPhone 13</a>
              </li>
          <li>
        <a href="/pixel-6" data-drupal-link-system-path="node/624076">Google Pixel 6</a>
              </li>
          <li>
        <a href="/galaxy-z-fold-3" data-drupal-link-system-path="node/627739">Samsung Galaxy Z Fold 3</a>
              </li>
          <li>
        <a href="/galaxy-z-flip-3" data-drupal-link-system-path="node/627741">Samsung Galaxy Z Flip 3</a>
              </li>
          <li>
        <a href="/samsung-galaxy-s21-review" data-drupal-link-system-path="node/585565">Samsung Galaxy S21 5G</a>
              </li>
          <li>
        <a href="/airpods-max" data-drupal-link-system-path="node/582644">Apple AirPods Max</a>
              </li>
          <li>
        <a href="/oneplus-9" data-drupal-link-system-path="node/590337">OnePlus 9</a>
              </li>
        </ul>
  


    </div>
  </div>

  <a class="navbar-brand" href="/"></a>

  <div class="navbar-content-menu">
    
              <ul class="menu is-content">
              <li>
        <a href="/iphone-13" data-drupal-link-system-path="node/633253">iPhone 13</a>
              </li>
          <li>
        <a href="/pixel-6" data-drupal-link-system-path="node/624076">Pixel 6</a>
              </li>
          <li>
        <a href="/galaxy-z-fold-3" data-drupal-link-system-path="node/627739">Galaxy Z Fold 3</a>
              </li>
          <li>
        <a href="/galaxy-z-flip-3" data-drupal-link-system-path="node/627741">Galaxy Z Flip 3</a>
              </li>
          <li>
        <a href="/samsung-galaxy-s22-faq" data-drupal-link-system-path="node/640930">Galaxy S22</a>
              </li>
          <li>
        <a href="/airpods-max" data-drupal-link-system-path="node/582644">AirPods Max</a>
              </li>
          <li>
        <a href="/oneplus-10-pro-official-snapdragon-8-gen-1-ltpo-display-and-80w-charging" data-drupal-link-system-path="node/640532">OnePlus 10 Pro</a>
              </li>
        </ul>
  


  </div>

  <div class="navbar-subscription-menu">
    
              <ul class="menu is-subscription">
              <li>
        <a href="https://www.youtube.com/user/pocketnowvideo" target="_blank"><i class="fa-fw fab fa-youtube"></i><span>YouTube</span></a>
              </li>
          <li>
        <a href="https://facebook.com/pocketnow" target="_blank"><i class="fa-fw fab fa-facebook-square"></i><span>Facebook</span></a>
              </li>
          <li>
        <a href="https://twitter.com/pocketnow" target="_blank"><i class="fa-fw fab fa-twitter"></i><span>Twitter</span></a>
              </li>
          <li>
        <a href="https://www.instagram.com/pocketnow/" target="_blank"><i class="fa-fw fab fa-instagram"></i><span>Instagram</span></a>
              </li>
          <li>
        <a href="/rss.xml" target="_blank" data-drupal-link-system-path="rss.xml"><i class="fa-fw fas fa-rss"></i><span>RSS Feeds</span></a>
              </li>
        </ul>
  


  </div>

  <div class="navbar-search">
    <button>
      <i class="fas fa-search"></i>
    </button>
      <div class="navbar-search-form">
        <form action="/search" method="get">
        <input type="text" name="query" placeholder="Search">
      </div>
    </form>
  </div>
</nav>

  </div>

</header>

<main class="page" role="main">
	  <div class="region region-content-header">
    
<div id="block-headeradunit" class="block block-block-content block-block-content1fcd69f2-7623-4010-b16b-83885fef15ce">
  
    
      
  </div>

<div id="block-affiliatedisclaimer" class="block block-block-content block-block-contentfccffb46-9674-414a-ac2b-faa2e8419965">
  
    
      <p>We are reader supported. <a href="/code-of-ethics">External links may earn us a commission</a>.</p>
  </div>

<div id="block-nyx-global-messages" class="block block-system block-system-messages-block">
  
    
        <div class="container">
      <div data-drupal-messages-fallback class="hidden"></div>
    </div>
  </div>

  </div>

  
	  <div class="region region-content-body">
    
<div id="block-nyx-global-content" class="block block-system block-system-main-block">
  
    
      

<article class="is-standard article is-full">
  <div class="container is-contained">
    <div class="columns">
      <div class="column is-main">
        <header>
          
<span class="category"><a href="/category/phones">Phones</a></span>

          

<h1 class="title is-article">Samsung to announce next Galaxy A series smartphones on March 17</h1>

          

<span class="subtitle is-article"></span>

          <div class="meta">
            

<span class="author">
  
      By <a href="/author/sanuj">Sanuj Bhatia</a>
  </span>

            

<span class="date">
  <i class="far fa-clock"></i> March 14, 2022, 1:30 am
</span>

          </div>
          <div class="community">
            


<ul class="social">
      <li>
      

<a class="is-social is-facebook button" href="https://www.facebook.com/sharer/sharer.php?u=https://pocketnow.com/samsung-galaxy-a-march-17-event-announced"><i class="fab fa-fw fa-facebook-f"></i> </a>
    </li>
      <li>
      

<a class="is-social is-twitter button" href="https://twitter.com/intent/tweet?url=https://pocketnow.com/samsung-galaxy-a-march-17-event-announced"><i class="fab fa-fw fa-twitter"></i> </a>
    </li>
      <li>
      

<a class="is-social is-pinterest button" href="https://pinterest.com/pin/create/button/?url=https://pocketnow.com/samsung-galaxy-a-march-17-event-announced"><i class="fab fa-fw fa-pinterest"></i> </a>
    </li>
      <li>
      

<a class="is-social is-linkedin button" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://pocketnow.com/samsung-galaxy-a-march-17-event-announced"><i class="fab fa-fw fa-linkedin-in"></i> </a>
    </li>
  </ul>

            

<span class="comment-count">
  <a href="#disqus_thread" data-disqus-identifier="641450 https://pocketnow.com/?p=641450"></a>

</span>

          </div>
          
        </header>
        <div class="content">
          

<figure class="image is-article is-full"><img srcset="/s3/files/styles/xsmall/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=1fzVQXFT 200w, https://media.pocketnow.com/styles/small/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=xN8yqE8R 400w, https://media.pocketnow.com/styles/medium/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=teatTSih 600w, https://media.pocketnow.com/styles/large/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=BnZe5YQf 800w, /s3/files/styles/xxlarge/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=PYZSJQes 920w" sizes="(min-width: 1300px) 745px, (min-width: 980px) calc(40vw + 233px), (min-width: 780px) calc(100vw - 595px), (min-width: 620px) calc(100vw - 270px), calc(100vw - 30px)" src="/s3/files/styles/xsmall/public/2022-03/Samsung%20Galaxy%20A%20event%20March%2017.jpg?itok=1fzVQXFT" alt="Samsung Galaxy A event March 17" typeof="foaf:Image"><span class="media-meta">
                    <cite>Source: Samsung</cite>
          </span>
  </figure>
<p>Samsung has been a lot active lately. The company first announced the <a href="https://pocketnow.com/tag/samsung-galaxy-s22">Galaxy S22 series</a> and the <a href="https://pocketnow.com/best-galaxy-tab-s8-deals">Galaxy Tab S8</a> series in early February and then finished off the month with the launch of the <a href="https://pocketnow.com/samsung-galaxy-book-2-pro-360-announcement">Galaxy Book 2 Pro 360</a> at MWC 2022. And the array of events doesn't seem to be stopping anytime soon as Samsung has now scheduled the Galaxy A Event for March 17.</p>
<p>Samsung is expected to announce Galaxy A52 and the Galaxy A73 smartphones at the event. The company introduced A52 around the same date last year and it is now tipped to launch its upgraded version later this week. For those looking to tune in, Samsung will be live streaming the event on its <a rel="nofollow noopener noreferrer" target="_blank" href="https://www.youtube.com/samsung">YouTube Channel</a> and <a rel="nofollow noopener noreferrer" target="_blank" href="https://news.samsung.com/global/">Samsung Newsroom website</a> from <strong>10 AM ET on March 17, 2022.</strong></p>
<p>Previous rumors have suggested that the <a href="https://pocketnow.com/samsung-galaxy-a53-price-and-case-leak">Galaxy A53</a> and the <a href="https://pocketnow.com/samsung-galaxy-a73-render-leak">Galaxy A73</a> will be minimal upgrades over the last-gen. Both the smartphone are expected to pick up 5G support. The Galaxy A53, in particular, is expected to come with a 6.46-inch 1080 × 2400 resolution display, 8GB RAM, 128/256GB storage, 4,860mAh battery, and an octa-core processor. On the other hand, the Galaxy A73 is expected to come with a 6.7-inch Super AMOLED display with a 120Hz refresh rate and FHD+ resolution.</p>
<p>In addition to these smartphones, Samsung might also announce low-end A33 and A23 smartphones. Thankfully, we'll get to know everything this Thursday. What are your expectations from Samsung's next-gen Galaxy A series smartphones? Let us know in the comments section below!</p>
<p><strong>Source</strong>: <a rel="nofollow noopener noreferrer" target="_blank" href="https://news.samsung.com/global/invitation-galaxy-a-event-democratizing-the-latest-galaxy-innovations-for-all">Samsung</a></p>
        </div>
        

<ul class="tags">
      <li><a href="/tag/samsung">Samsung</a></li>
      <li><a href="/tag/news">News</a></li>
      <li><a href="/tag/samsung-galaxy-a53">Samsung Galaxy A53</a></li>
      <li><a href="/tag/samsung-galaxy-a73">Samsung Galaxy A73</a></li>
  </ul>

        

<div class="related">
  <h2 class="related-heading">Read More</h2>
  
<article class="article is-stub">
      
<a href="/iphone-14-pro-a16-chip-report" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="https://media.pocketnow.com/styles/xsmall/public/2021-12/iPhone%2014%20with%20hole-punch%20cutout.jpg?itok=mgzxLKx_ 200w, https://media.pocketnow.com/styles/small/public/2021-12/iPhone%2014%20with%20hole-punch%20cutout.jpg?itok=kZYLwIic 400w, https://media.pocketnow.com/styles/medium/public/2021-12/iPhone%2014%20with%20hole-punch%20cutout.jpg?itok=34gFfsu_ 600w, https://media.pocketnow.com/styles/large/public/2021-12/iPhone%2014%20with%20hole-punch%20cutout.jpg?itok=LDcNjaCl 800w, https://media.pocketnow.com/styles/xlarge/public/2021-12/iPhone%2014%20with%20hole-punch%20cutout.jpg?itok=A-Wz3H_8 1200w, https://media.pocketnow.com/styles/xxlarge/public/2021-12/iPhone%2014%20with%20hole-punch%20cutout.jpg?itok=hlttcXOg 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="https://media.pocketnow.com/styles/xsmall/public/2021-12/iPhone%2014%20with%20hole-punch%20cutout.jpg?itok=mgzxLKx_" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/phones">Phones</a></span>

  

<h2 class="title is-article">
      <a href="/iphone-14-pro-a16-chip-report">Report: iPhone 14 Pro models to get new A16 chip, standard models to retain A15 Bionic</a>
  </h2>

  <p class="summary is-article">Popular Apple analyst Ming-Chi Kuo has shared some of the specs of the iPhone 14 series. He says that only the Pro models will get the new A16 chip. Learn more here.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Sanuj Bhatia</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 13, 2022, 12:45 pm
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/which-galaxy-s22-storage-should-i-buy" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="https://media.pocketnow.com/styles/xsmall/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=f73n-aBf 200w, https://media.pocketnow.com/styles/small/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=-S2XRjLA 400w, https://media.pocketnow.com/styles/medium/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=51WP3ga3 600w, https://media.pocketnow.com/styles/large/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=XHJnEbnv 800w, https://media.pocketnow.com/styles/xlarge/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=LMaxt_k- 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=SrzqWEd0 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="https://media.pocketnow.com/styles/xsmall/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=f73n-aBf" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/phones">Phones</a></span>

  

<h2 class="title is-article">
      <a href="/which-galaxy-s22-storage-should-i-buy">What storage size do you need for the Galaxy S22?</a>
  </h2>

  <p class="summary is-article">Want to get Samsung's new flagships, but can't figure out the storage variant to buy? We'll assist you to pick the right Galaxy S22 storage size.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Sanuj Bhatia</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 13, 2022, 12:00 pm
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/galaxy-s22-ultra-leather-cases" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="https://media.pocketnow.com/styles/xsmall/public/2022-02/LI%20Samsung%20Galaxy%20S22%20Ultra%20Display%20with%20S%20Pen.jpg?itok=lVGg4-q7 200w, https://media.pocketnow.com/styles/small/public/2022-02/LI%20Samsung%20Galaxy%20S22%20Ultra%20Display%20with%20S%20Pen.jpg?itok=oXJkKbcR 400w, https://media.pocketnow.com/styles/medium/public/2022-02/LI%20Samsung%20Galaxy%20S22%20Ultra%20Display%20with%20S%20Pen.jpg?itok=gluLo0_p 600w, https://media.pocketnow.com/styles/large/public/2022-02/LI%20Samsung%20Galaxy%20S22%20Ultra%20Display%20with%20S%20Pen.jpg?itok=qGkeHwc5 800w, https://media.pocketnow.com/styles/xlarge/public/2022-02/LI%20Samsung%20Galaxy%20S22%20Ultra%20Display%20with%20S%20Pen.jpg?itok=CqKePaAm 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-02/LI%20Samsung%20Galaxy%20S22%20Ultra%20Display%20with%20S%20Pen.jpg?itok=GpmOH2pZ 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="https://media.pocketnow.com/styles/xsmall/public/2022-02/LI%20Samsung%20Galaxy%20S22%20Ultra%20Display%20with%20S%20Pen.jpg?itok=lVGg4-q7" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/android">Android</a></span>

  

<h2 class="title is-article">
      <a href="/galaxy-s22-ultra-leather-cases">These are the best Galaxy S22 Ultra leather cases</a>
  </h2>

  <p class="summary is-article">We have collected some of the best Samsung Galaxy S22 Ultra leather cases that are currently available in the market so you can keep your new device safe and looking sexy</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Samuel Martinez</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 12, 2022, 4:00 am
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/pocketnow-daily-samsung-addresses-galaxy-s22-throttling-confusing-new-mac-leaks-more-video" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="/s3/files/styles/xsmall/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=f73n-aBf 200w, /s3/files/styles/small/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=-S2XRjLA 400w, https://media.pocketnow.com/styles/medium/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=51WP3ga3 600w, https://media.pocketnow.com/styles/large/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=XHJnEbnv 800w, /s3/files/styles/xlarge/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=LMaxt_k- 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=SrzqWEd0 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="/s3/files/styles/xsmall/public/2022-03/S22%20Plus%20in%20hand.jpg?itok=f73n-aBf" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/android">Android</a></span>

  

<h2 class="title is-article">
      <a href="/pocketnow-daily-samsung-addresses-galaxy-s22-throttling-confusing-new-mac-leaks-more-video">Pocketnow Daily: Samsung Addresses Galaxy S22 Throttling, CONFUSING New Mac Leaks &amp; more! (video)</a>
  </h2>

  <p class="summary is-article">On today’s Pocketnow Daily, we talk about Samsung's actions after been caught throttling its flagship devices, new MacBook Air rumors, and more.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Samuel Martinez</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 11, 2022, 8:54 pm
</span>

    <!-- comments -->
  </div>
</article>
</div>

        
<div id="disqus_thread"></div>


      </div>
      <div class="column is-sidebar">
                  <nav role="navigation" aria-labelledby="block-subscription-menu" id="block-subscription">
      
  <h2 id="block-subscription-menu">Follow Us</h2>
  

        
              <ul class="menu is-subscription">
              <li>
        <a href="https://www.youtube.com/user/pocketnowvideo" target="_blank"><i class="fa-fw fab fa-youtube"></i><span>YouTube</span></a>
              </li>
          <li>
        <a href="https://facebook.com/pocketnow" target="_blank"><i class="fa-fw fab fa-facebook-square"></i><span>Facebook</span></a>
              </li>
          <li>
        <a href="https://twitter.com/pocketnow" target="_blank"><i class="fa-fw fab fa-twitter"></i><span>Twitter</span></a>
              </li>
          <li>
        <a href="https://www.instagram.com/pocketnow/" target="_blank"><i class="fa-fw fab fa-instagram"></i><span>Instagram</span></a>
              </li>
          <li>
        <a href="/rss.xml" target="_blank" data-drupal-link-system-path="rss.xml"><i class="fa-fw fas fa-rss"></i><span>RSS Feeds</span></a>
              </li>
        </ul>
  


  </nav>

                  
<div class="views-exposed-form block block-views block-views-exposed-filter-blocksearch-page-1" data-drupal-selector="views-exposed-form-search-page-1" id="block-exposedformsearchpage-1">
  
      <div class="block-title">
      <h2 class="is-block-title">Search</h2>
    </div>
    
      <form action="/search" method="get" id="views-exposed-form-search-page-1" accept-charset="UTF-8">
  <div class="js-form-item form-item js-form-type-textfield form-item-query js-form-item-query">
      <label for="edit-query">Search</label>
        <input data-drupal-selector="edit-query" type="text" id="edit-query" name="query" value="" size="30" maxlength="128" class="form-text" />

        </div>
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions"><input data-drupal-selector="edit-submit-search" type="submit" id="edit-submit-search" value="Apply" class="button js-form-submit form-submit" />
</div>


</form>

  </div>

                  
  <div class="block block-nyx-blocks block-nyx-blocks-article is-compact" id="block-articleblock">
  
      <div class="block-title">
      <h2 class="is-block-title">Latest Articles</h2>
    </div>
    
    
<article class="article is-stub">
      
<a href="/apple-mac-studio-rumor" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="https://media.pocketnow.com/styles/xsmall/public/2021/07/Mac-Mini-Featured-Image.jpg?itok=zmxuPk5c 200w, https://media.pocketnow.com/styles/small/public/2021/07/Mac-Mini-Featured-Image.jpg?itok=NFBDNSIO 400w, https://media.pocketnow.com/styles/medium/public/2021/07/Mac-Mini-Featured-Image.jpg?itok=G84BlN-i 600w, https://media.pocketnow.com/styles/large/public/2021/07/Mac-Mini-Featured-Image.jpg?itok=3y-DFm3Z 800w, https://media.pocketnow.com/styles/xxlarge/public/2021/07/Mac-Mini-Featured-Image.jpg?itok=_1eW-MKe 1200w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="https://media.pocketnow.com/styles/xsmall/public/2021/07/Mac-Mini-Featured-Image.jpg?itok=zmxuPk5c" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/mac">mac</a></span>

  

<h2 class="title is-article">
      <a href="/apple-mac-studio-rumor">Apple Mac Studio could be the company&#039;s powerful Mac mini and Mac Pro hybrid </a>
  </h2>

  <p class="summary is-article">According to a new report, Apple is working on a new category of desktop Mac called Mac Studio. It is said to sit in between Mac mini and Mac Pro. Learn more about the upcoming Apple Mac Studio here.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Sanuj Bhatia</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 3:30 pm
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/apples-airpods-pro-oneplus-9-and-other-great-products-are-sale" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="https://media.pocketnow.com/styles/xsmall/public/2021/10/AirPods-Pro-craclink-static-sound-issue-apple-warranty-extended.jpg?itok=J_dD1Z6e 200w, https://media.pocketnow.com/styles/small/public/2021/10/AirPods-Pro-craclink-static-sound-issue-apple-warranty-extended.jpg?itok=-9wAMo-G 400w, https://media.pocketnow.com/styles/medium/public/2021/10/AirPods-Pro-craclink-static-sound-issue-apple-warranty-extended.jpg?itok=9V_5iGiL 600w, https://media.pocketnow.com/styles/large/public/2021/10/AirPods-Pro-craclink-static-sound-issue-apple-warranty-extended.jpg?itok=FFrnF0Cj 800w, https://media.pocketnow.com/styles/xxlarge/public/2021/10/AirPods-Pro-craclink-static-sound-issue-apple-warranty-extended.jpg?itok=cNu9N02X 1200w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="https://media.pocketnow.com/styles/xsmall/public/2021/10/AirPods-Pro-craclink-static-sound-issue-apple-warranty-extended.jpg?itok=J_dD1Z6e" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/deals">Deals</a></span>

  

<h2 class="title is-article">
      <a href="/apples-airpods-pro-oneplus-9-and-other-great-products-are-sale">Apple’s AirPods Pro, OnePlus 9, and other great products are on sale</a>
  </h2>

  <p class="summary is-article">Check out the latest deals available on some of Apple's best earphones, including the AirPods Pro, the third generation AirPods and other great products</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Samuel Martinez</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 2:52 pm
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/apple-studio-display-reportedly-under-development-7k-resolution" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="https://media.pocketnow.com/styles/xsmall/public/2022-01/Apple%20Pro%20Display%20XDR.jpg?itok=9hJ_dSM0 200w, https://media.pocketnow.com/styles/small/public/2022-01/Apple%20Pro%20Display%20XDR.jpg?itok=I-jQrZJW 400w, https://media.pocketnow.com/styles/medium/public/2022-01/Apple%20Pro%20Display%20XDR.jpg?itok=H-jHr_9I 600w, https://media.pocketnow.com/styles/large/public/2022-01/Apple%20Pro%20Display%20XDR.jpg?itok=oCiA5DZD 800w, https://media.pocketnow.com/styles/xlarge/public/2022-01/Apple%20Pro%20Display%20XDR.jpg?itok=nrmia59Z 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-01/Apple%20Pro%20Display%20XDR.jpg?itok=qRiRrAFj 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="https://media.pocketnow.com/styles/xsmall/public/2022-01/Apple%20Pro%20Display%20XDR.jpg?itok=9hJ_dSM0" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/mac">mac</a></span>

  

<h2 class="title is-article">
      <a href="/apple-studio-display-reportedly-under-development-7k-resolution">&#039;Apple Studio Display&#039; reportedly under development with 7K resolution</a>
  </h2>

  <p class="summary is-article">According to a new report, Apple is developing an even higher resolution display than Pro Display XDR called Apple Studio Display. Here's everything you need to know about it.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Sanuj Bhatia</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 2:12 pm
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/volvo-wireless-charging-ev" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="/s3/files/styles/xsmall/public/2022-03/LI%20Volvo%20wireless%20charging%20ev.jpg?itok=o216oSsR 200w, https://media.pocketnow.com/styles/small/public/2022-03/LI%20Volvo%20wireless%20charging%20ev.jpg?itok=UtKSNJHH 400w, https://media.pocketnow.com/styles/medium/public/2022-03/LI%20Volvo%20wireless%20charging%20ev.jpg?itok=SMNV22Jz 600w, /s3/files/styles/large/public/2022-03/LI%20Volvo%20wireless%20charging%20ev.jpg?itok=Q9Ksv3Vu 800w, /s3/files/styles/xlarge/public/2022-03/LI%20Volvo%20wireless%20charging%20ev.jpg?itok=qxGaU_59 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-03/LI%20Volvo%20wireless%20charging%20ev.jpg?itok=gG-WD8hB 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="/s3/files/styles/xsmall/public/2022-03/LI%20Volvo%20wireless%20charging%20ev.jpg?itok=o216oSsR" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/evs">EVs</a></span>

  

<h2 class="title is-article">
      <a href="/volvo-wireless-charging-ev">Volvo begins testing a wireless charging solution for its electric vehicles</a>
  </h2>

  <p class="summary is-article">Volvo today announced that it will start testing a wireless charging technology for its electric vehicles. The tests will be conducted in Gothenburg, Sweden, and take over three years.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Roland Udvarlaki</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 1:03 pm
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/android-13-hub-mode-tablets" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="https://media.pocketnow.com/styles/xsmall/public/2021-12/android%2013%20tiramisu%20pocketnow.png?itok=EqxxSYUd 200w, https://media.pocketnow.com/styles/small/public/2021-12/android%2013%20tiramisu%20pocketnow.png?itok=CcID7Yc- 400w, https://media.pocketnow.com/styles/medium/public/2021-12/android%2013%20tiramisu%20pocketnow.png?itok=vzmiSTrh 600w, https://media.pocketnow.com/styles/large/public/2021-12/android%2013%20tiramisu%20pocketnow.png?itok=B2xxCKRB 800w, https://media.pocketnow.com/styles/xlarge/public/2021-12/android%2013%20tiramisu%20pocketnow.png?itok=3qbYqaKk 1200w, https://media.pocketnow.com/styles/xxlarge/public/2021-12/android%2013%20tiramisu%20pocketnow.png?itok=V6WPUmp1 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="https://media.pocketnow.com/styles/xsmall/public/2021-12/android%2013%20tiramisu%20pocketnow.png?itok=EqxxSYUd" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/android">Android</a></span>

  

<h2 class="title is-article">
      <a href="/android-13-hub-mode-tablets">Android 13 could come with a Hub Mode and improve the tablet experience</a>
  </h2>

  <p class="summary is-article">According to some new information, Android 13 may go a step further and introduce a Hub Mode for tables, and even more improvements for tablets and other large-screen devices.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Roland Udvarlaki</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 12:00 pm
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/samsung-galaxy-m23-m33-announcement" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="/s3/files/styles/xsmall/public/2022-03/LI%20Samsung%20Galaxy%20M23%20and%20M33%20devices%202022.jpeg?itok=rd3c6isg 200w, /s3/files/styles/small/public/2022-03/LI%20Samsung%20Galaxy%20M23%20and%20M33%20devices%202022.jpeg?itok=ASuYjc4O 400w, https://media.pocketnow.com/styles/medium/public/2022-03/LI%20Samsung%20Galaxy%20M23%20and%20M33%20devices%202022.jpeg?itok=tdElIS8n 600w, /s3/files/styles/large/public/2022-03/LI%20Samsung%20Galaxy%20M23%20and%20M33%20devices%202022.jpeg?itok=ayVeRGvw 800w, /s3/files/styles/xlarge/public/2022-03/LI%20Samsung%20Galaxy%20M23%20and%20M33%20devices%202022.jpeg?itok=fT8qZ6t6 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-03/LI%20Samsung%20Galaxy%20M23%20and%20M33%20devices%202022.jpeg?itok=xH8xzzbu 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="/s3/files/styles/xsmall/public/2022-03/LI%20Samsung%20Galaxy%20M23%20and%20M33%20devices%202022.jpeg?itok=rd3c6isg" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/phones">Phones</a></span>

  

<h2 class="title is-article">
      <a href="/samsung-galaxy-m23-m33-announcement">Samsung Galaxy M23 and M33 are unveiled with 6.6-inch displays and 50MP cameras</a>
  </h2>

  <p class="summary is-article">Samsung appears to be having a busy day, and it just unveiled the brand new Samsung Galaxy M23 5G and Galaxy M33 5G affordable smartphones. Here are the specifications.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Roland Udvarlaki</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 10:55 am
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/samsung-galaxy-a13-a23-2022-announcement" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="/s3/files/styles/xsmall/public/2022-03/LI%20Samsung%20Galaxy%20A13%20and%20A23%20devices%202022_0.jpeg?itok=iLMmy8Z- 200w, /s3/files/styles/small/public/2022-03/LI%20Samsung%20Galaxy%20A13%20and%20A23%20devices%202022_0.jpeg?itok=1PTxqvUq 400w, https://media.pocketnow.com/styles/medium/public/2022-03/LI%20Samsung%20Galaxy%20A13%20and%20A23%20devices%202022_0.jpeg?itok=p7A46gxi 600w, /s3/files/styles/large/public/2022-03/LI%20Samsung%20Galaxy%20A13%20and%20A23%20devices%202022_0.jpeg?itok=YrrXZpbl 800w, /s3/files/styles/xlarge/public/2022-03/LI%20Samsung%20Galaxy%20A13%20and%20A23%20devices%202022_0.jpeg?itok=gHyIiiZD 1200w, /s3/files/styles/xxlarge/public/2022-03/LI%20Samsung%20Galaxy%20A13%20and%20A23%20devices%202022_0.jpeg?itok=MBRQe778 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="/s3/files/styles/xsmall/public/2022-03/LI%20Samsung%20Galaxy%20A13%20and%20A23%20devices%202022_0.jpeg?itok=iLMmy8Z-" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/phones">Phones</a></span>

  

<h2 class="title is-article">
      <a href="/samsung-galaxy-a13-a23-2022-announcement">Samsung Galaxy A13 and A23 are officially unveiled with 6.6-inch displays</a>
  </h2>

  <p class="summary is-article">The Galaxy A series are some of the best-selling Samsung smartphones, and the Galaxy A13 4G and A23 4G are the latest additions to join the lineup.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Roland Udvarlaki</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 9:48 am
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/xbox-app-windows-modding" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="/s3/files/styles/xsmall/public/2022-03/LI%20Xbox%20Game%20Pass.jpg?itok=d3L7UQCt 200w, /s3/files/styles/small/public/2022-03/LI%20Xbox%20Game%20Pass.jpg?itok=0Fuxsor4 400w, https://media.pocketnow.com/styles/medium/public/2022-03/LI%20Xbox%20Game%20Pass.jpg?itok=cfn92BF_ 600w, /s3/files/styles/large/public/2022-03/LI%20Xbox%20Game%20Pass.jpg?itok=6Ml_Ljxc 800w, /s3/files/styles/xlarge/public/2022-03/LI%20Xbox%20Game%20Pass.jpg?itok=7w8kQIPc 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-03/LI%20Xbox%20Game%20Pass.jpg?itok=xNnbmrvZ 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="/s3/files/styles/xsmall/public/2022-03/LI%20Xbox%20Game%20Pass.jpg?itok=d3L7UQCt" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/gaming">Gaming</a></span>

  

<h2 class="title is-article">
      <a href="/xbox-app-windows-modding">Xbox app on Windows lets users change installation path, use mods and more</a>
  </h2>

  <p class="summary is-article">In a new announcement, the Xbox announced several new games coming to the platform, new updates to existing games, and new features that are finally making their way to the Xbox app on Windows.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Roland Udvarlaki</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 7:45 am
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/google-will-soon-allow-you-disable-chrome-os-automatic-updates" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="https://media.pocketnow.com/styles/xsmall/public/2022-02/Chrome%20OS%20on%20Mac.jpg?itok=fv-82Vae 200w, https://media.pocketnow.com/styles/small/public/2022-02/Chrome%20OS%20on%20Mac.jpg?itok=pWXyjMiX 400w, https://media.pocketnow.com/styles/medium/public/2022-02/Chrome%20OS%20on%20Mac.jpg?itok=aujcLbqZ 600w, https://media.pocketnow.com/styles/large/public/2022-02/Chrome%20OS%20on%20Mac.jpg?itok=OfNfaTat 800w, https://media.pocketnow.com/styles/xlarge/public/2022-02/Chrome%20OS%20on%20Mac.jpg?itok=ZD87xkUu 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-02/Chrome%20OS%20on%20Mac.jpg?itok=OCEnrGtE 1600w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="https://media.pocketnow.com/styles/xsmall/public/2022-02/Chrome%20OS%20on%20Mac.jpg?itok=fv-82Vae" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/chrome-os">Chrome OS</a></span>

  

<h2 class="title is-article">
      <a href="/google-will-soon-allow-you-disable-chrome-os-automatic-updates">Google will soon allow you to disable Chrome OS automatic updates</a>
  </h2>

  <p class="summary is-article">Google will reportedly allow Chromebook users to disable automatic Chrome OS updates. Click here for more details.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Sanuj Bhatia</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 7:00 am
</span>

    <!-- comments -->
  </div>
</article>
<article class="article is-stub">
      
<a href="/xiaomi-12-and-12-pro-prices-leak-ahead-global-launch" class="image is-article is-stub is-4by3">
  <figure>
    <img srcset="/s3/files/styles/xsmall/public/2022-03/Xiaomi%2012%201.jpg?itok=h0VD31ir 200w, /s3/files/styles/small/public/2022-03/Xiaomi%2012%201.jpg?itok=PNulGZpD 400w, https://media.pocketnow.com/styles/medium/public/2022-03/Xiaomi%2012%201.jpg?itok=q_bqZEi2 600w, /s3/files/styles/large/public/2022-03/Xiaomi%2012%201.jpg?itok=MJV23pN0 800w, /s3/files/styles/xlarge/public/2022-03/Xiaomi%2012%201.jpg?itok=kPq_q8zi 1200w, https://media.pocketnow.com/styles/xxlarge/public/2022-03/Xiaomi%2012%201.jpg?itok=yOWKDqQZ 1536w" sizes="(min-width: 1160px) 350px, (min-width: 500px) 31.25vw, calc(100vw - 30px)" src="/s3/files/styles/xsmall/public/2022-03/Xiaomi%2012%201.jpg?itok=h0VD31ir" alt="" typeof="foaf:Image" />
  </figure>
</a>


    
<span class="category"><a href="/category/phones">Phones</a></span>

  

<h2 class="title is-article">
      <a href="/xiaomi-12-and-12-pro-prices-leak-ahead-global-launch">Xiaomi 12 and 12 Pro prices leak ahead of global launch</a>
  </h2>

  <p class="summary is-article">A new report suggests the upcoming Xiaomi 12 and Xiaomi 12 Pro flagship devices might cost premium prices in Europe. Another report also gives us a quick look at the new Xiaomi Watch S1 Active smartwatch.</p>
  <div class="meta">
    

<span class="author">
  
      By <span>Roland Udvarlaki</span>
  </span>

    

<span class="date">
  <i class="far fa-clock"></i> March 4, 2022, 6:45 am
</span>

    <!-- comments -->
  </div>
</article>
  <div class="more-link">
    
  </div>
</div>

              </div>
    </div>
  </div>
</article>


  </div>

  </div>

	
</main>

<footer>
	  <div class="region region-page-footer">
    <nav role="navigation" aria-labelledby="block-footer-menu" id="block-footer">
            
  <h2 class="visually-hidden" id="block-footer-menu">Footer</h2>
  

        
              <ul class="menu is-footer">
              <li>
        <a href="/about-us-pocketnow" data-drupal-link-system-path="node/639775">About Us</a>
              </li>
          <li>
        <a href="/contact-us-pocketnow" data-drupal-link-system-path="node/639780">Contact Us</a>
              </li>
          <li>
        <a href="/tip-us" data-drupal-link-system-path="node/639781">Tip Us</a>
              </li>
          <li>
        <a href="/terms-and-conditions" data-drupal-link-system-path="node/639776">Terms and Conditions</a>
              </li>
          <li>
        <a href="/privacy-policy" data-drupal-link-system-path="node/639777">Privacy Policy</a>
              </li>
          <li>
        <span>© Pocketnow.com. All rights reserved - Busy Pixel Media</span>
              </li>
        </ul>
  


  </nav>

  </div>

</footer>


  </div>

    
    <script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/641450","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ajaxTrustedUrl":{"\/search":true},"disqus":{"id":"641450 https:\/\/pocketnow.com\/?p=641450","site_name":"pocketnow"},"user":{"uid":0,"permissionsHash":"b8cacf221d44f9f3286a8e20b9d302f933569b0b51dacbe10737df119ae02412"}}</script>
<script src="/sites/pocketnow/files/js/js_fNBcs6MK2bK1aR65w0ncbDv-WCpZPgxtCqGOh59fonY.js"></script>
<script src="//pocketnow.disqus.com/count.js" async id="dsq-count-scr"></script>
<script src="//cdn.parsely.com/keys/pocketnow.com/p.js" id="parsely-cfg"></script>
<script src="/sites/pocketnow/files/js/js_GldmT_MzDPANlwfcyU_P2bW1DFJnpvH50JBkII6cLP0.js"></script>

  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"755a85aa7e","applicationID":"568654343","transactionName":"YAdXYUpUChEEUEBRC1lNdFZMXAsMSkNVXwFoAVRWUFA=","queueTime":0,"applicationTime":21,"atts":"TEBUFwJOGR8=","errorBeacon":"bam.nr-data.net","agent":""}</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6ebaebefff695c64","token":"8149c355359041b48f5711df1c3d21b2","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>
