<!DOCTYPE HTML>
<html lang="en-US">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no">
<meta name="msvalidate.01" content="1F96B84F19C712498ACCB2769C086E63" />
<meta property="fb:app_id" content="701756623345883" />
<script>
    var isMobile = false;
    if (/Mobi|Android/i.test(navigator.userAgent)) {
      isMobile = true;
    }
  </script>
<script type="text/javascript">!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://quietknowledge.com/v2/0/veumOruX-Ehp31QoO8GR7bwxk7G31v0TisYmI4H7maP2ezxNguJigXGT2RJDOxsCuivvYrTkve-",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,n,e,o){function r(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(n){}return!1}function c(){var o=r();if(o){var c=t[n].pubads();typeof c.setTargeting===e&&c.setTargeting("admiral-engaged","true")}}o=t[n]=t[n]||{},o.cmd=o.cmd||[],typeof o.pubads===e?c():typeof o.cmd.unshift===e?o.cmd.unshift(c):o.cmd.push(c)}(window,"googletag","function");;;;;</script>
<link media="screen, projection, print" rel="stylesheet" href="https://pocketnow.com/wp-content/themes/techwise-child/style.css" type="text/css" />
<link rel="shortcut icon" href="https://pocketnow.com/wp-content/uploads/2017/06/icon.ico" />
<meta property="og:image" content="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage.jpg" />
<link rel="pingback" href="https://pocketnow.com/xmlrpc.php" />
<title>How to fix your phone&#039;s shitty portrait mode | Pocketnow</title>

<meta name="description" content="Smartphones are getting better at photography, but they are still lacking in the bokeh blur department especially for the portrait mode. Here&#039;s a fix!" />
<link rel="canonical" href="https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to fix your phone&#039;s shitty portrait mode | Pocketnow" />
<meta property="og:description" content="Smartphones are getting better at photography, but they are still lacking in the bokeh blur department especially for the portrait mode. Here&#039;s a fix!" />
<meta property="og:url" content="https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode" />
<meta property="og:site_name" content="Pocketnow" />
<meta property="article:publisher" content="http://facebook.com/pocketnow" />
<meta property="article:tag" content="Background blur" />
<meta property="article:tag" content="Depth Map" />
<meta property="article:tag" content="Editorial" />
<meta property="article:tag" content="iPhone" />
<meta property="article:tag" content="Photoshop" />
<meta property="article:tag" content="Portrait Mode" />
<meta property="article:section" content="Android" />
<meta property="article:published_time" content="2019-07-24T12:00:02+00:00" />
<meta property="article:modified_time" content="2019-07-24T13:21:41+00:00" />
<meta property="og:updated_time" content="2019-07-24T13:21:41+00:00" />
<meta property="og:image" content="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage.jpg" />
<meta property="og:image:secure_url" content="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage.jpg" />
<meta property="og:image:width" content="780" />
<meta property="og:image:height" content="585" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Smartphones are getting better at photography, but they are still lacking in the bokeh blur department especially for the portrait mode. Here&#039;s a fix!" />
<meta name="twitter:title" content="How to fix your phone&#039;s shitty portrait mode | Pocketnow" />
<meta name="twitter:site" content="@pocketnow" />
<meta name="twitter:image" content="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage.jpg" />
<meta name="twitter:creator" content="@adamzea" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://pocketnow.com/#organization","name":"Pocketnow","url":"https://pocketnow.com/","sameAs":["http://facebook.com/pocketnow","https://www.instagram.com/pocketnow/","https://www.youtube.com/pocketnow","https://twitter.com/pocketnow"],"logo":{"@type":"ImageObject","@id":"https://pocketnow.com/#logo","url":"https://pocketnow.com/wp-content/uploads/2016/11/LogoX4.png","width":357,"height":140,"caption":"Pocketnow"},"image":{"@id":"https://pocketnow.com/#logo"}},{"@type":"WebSite","@id":"https://pocketnow.com/#website","url":"https://pocketnow.com/","name":"Pocketnow","publisher":{"@id":"https://pocketnow.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://pocketnow.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode#primaryimage","url":"https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage.jpg","width":780,"height":585},{"@type":"WebPage","@id":"https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode#webpage","url":"https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode","inLanguage":"en-US","name":"How to fix your phone&#039;s shitty portrait mode | Pocketnow","isPartOf":{"@id":"https://pocketnow.com/#website"},"primaryImageOfPage":{"@id":"https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode#primaryimage"},"datePublished":"2019-07-24T12:00:02+00:00","dateModified":"2019-07-24T13:21:41+00:00","description":"Smartphones are getting better at photography, but they are still lacking in the bokeh blur department especially for the portrait mode. Here's a fix!"},{"@type":"Article","@id":"https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode#article","isPartOf":{"@id":"https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode#webpage"},"author":{"@id":"https://pocketnow.com/#/schema/person/60aaaa5696c9ebc60085ea7d3c66be36"},"headline":"How to fix your phone&#8217;s shitty portrait mode","datePublished":"2019-07-24T12:00:02+00:00","dateModified":"2019-07-24T13:21:41+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode#webpage"},"publisher":{"@id":"https://pocketnow.com/#organization"},"image":{"@id":"https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode#primaryimage"},"keywords":"Background blur,Depth Map,Editorial,iPhone,Photoshop,Portrait Mode","articleSection":"Android,iOS,Phones"},{"@type":["Person"],"@id":"https://pocketnow.com/#/schema/person/60aaaa5696c9ebc60085ea7d3c66be36","name":"Adam Z. Lein","image":{"@type":"ImageObject","@id":"https://pocketnow.com/#authorlogo","url":"https://pocketnow.com/wp-content/uploads/2012/07/Adam-96x96.jpg","caption":"Adam Z. Lein"},"description":"Adam has had interests in combining technology with art since his first use of a Koala pad on an Apple computer. He currently has a day job as a graphic designer, photographer, systems administrator and web developer at a small design firm in Westchester, NY. His love of technology extends to software development companies who have often implemented his ideas for usability and feature enhancements. Mobile computing has become a necessity for Adam since his first Uniden UniPro PC100 in 1998. He has been reviewing and writing about smartphones for Pocketnow.com since they first appeared on the market in 2002. <a href=\"http://pocketnow.com/2013/06/01/get-to-know-adam-lein\">Read more about Adam Lein!</a>","sameAs":["https://twitter.com/adamzea"]}]}</script>

<link rel="amphtml" href="https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode/amp?utm_source=feedburner&#038;utm_medium=feed&#038;utm_campaign=Feed:%20pocketnow%20(pocketnow.com)" /><meta name="generator" content="AMP for WP 0.9.97.65" /><link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Pocketnow &raquo; Feed" href="https://pocketnow.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Pocketnow &raquo; Comments Feed" href="https://pocketnow.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Pocketnow &raquo; How to fix your phone&#8217;s shitty portrait mode Comments Feed" href="https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode/feed" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/pocketnow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://pocketnow.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css' href='https://pocketnow.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='ads-for-wp-front-css-css' href='https://pocketnow.com/wp-content/plugins/ads-for-wp/public/assets/css/adsforwp-front.min.css?ver=1.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://pocketnow.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css' href='https://pocketnow.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://pocketnow.com/wp-content/themes/techwise/style.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='css_overrides_css-css' href='https://pocketnow.com/wp-content/themes/techwise-child/css/overrides.css?ver=1561467044' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://pocketnow.com/wp-content/plugins/easy-table/themes/default/style.css?ver=1.8' type='text/css' media='all' />
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Ui = {"text":{"latest_in":"Latest In","at_least_3char":"Search term must be at least 3 characters in length"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/themes/techwise-child/js/ui.js?ver=1561466844'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var itAjax = {"ajaxurl":"https:\/\/pocketnow.com\/wp-admin\/admin-ajax.php","xDebug":"300"};
/* ]]> */
</script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/themes/techwise-child/js/ajax.js?ver=1561466844'></script>
<link rel='https://api.w.org/' href='https://pocketnow.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://pocketnow.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://pocketnow.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://pocketnow.com/?p=546172' />
<link rel="alternate" type="application/json+oembed" href="https://pocketnow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpocketnow.com%2Fhow-to-fix-your-phones-shitty-portrait-mode" />
<link rel="alternate" type="text/xml+oembed" href="https://pocketnow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpocketnow.com%2Fhow-to-fix-your-phones-shitty-portrait-mode&#038;format=xml" />
<script type="text/javascript">              
              jQuery(document).ready( function($) {    
                  if ($('#adsforwp-hidden-block').length == 0 ) {
                       $.getScript("https://pocketnow.com/front.js");
                  }
                 
              });
         </script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
                                    var googletag = googletag || {};
                                    googletag.cmd = googletag.cmd || [];
                                  </script>
<script>
                                    googletag.cmd.push(function() {                                                   
                                      googletag.defineSlot('', [, ], '').addService(googletag.pubads());  
                                      googletag.pubads().enableSingleRequest();
                                      googletag.enableServices();
                                    });
                                  </script><div class="textwidget custom-html-widget">
<script data-cfasync="false" async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-cfasync="false">
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-2900107662879704",
          enable_page_level_ads: true,
              overlays: {bottom: true}
     });
</script>
</div> 
<script>
      window.dataLayer = window.dataLayer || [];
      function gtag(){dataLayer.push(arguments);}
      gtag('js', new Date());
      gtag('config', 'UA-93175-1', { 'optimize_id': 'GTM-TJWC8RL'});
    </script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-93175-1"></script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>
<script>
        googletag.cmd.push(function() {
            googletag.defineSlot('/7346874/Hellobar-adunits/HB_PN', [1, 1], 'div-gpt-ad-1556738214300-0').addService(googletag.pubads());
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
        });
    </script>
</head>
<body class="post-template-default single single-post postid-546172 single-format-standard no-js it-background woocommerce bp-page category-15 colorbox-enabled colorbox-slideshow-off is-single">
<div id="fb-root"></div>
<div id="ajax-error"></div>

<div id='div-gpt-ad-1556738214300-0' style='height:1px; width:1px;'>
<script>
          googletag.cmd.push(function() { googletag.display('div-gpt-ad-1556738214300-0'); });
      </script>
</div>
<div class="container-fluid no-padding">
<div id="logo-bar" class=" no-topbar">
<div class="row">
<div class="col-md-12">
<div id="logo-bar-inner" class="container-inner">
<div class='widgets' id="logo-widget">
<ul>
</ul>
</div>
<div id="logo">
<a href="https://pocketnow.com/">
<img id="site-logo" alt="Pocketnow" src="https://pocketnow.com/wp-content/uploads/2016/11/LogoX4.png" width="89" height="35" />
<img id="site-logo-hd" alt="Pocketnow" src="https://pocketnow.com/wp-content/uploads/2016/11/LogoX4.png" width="89" height="35" />
</a>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container-fluid no-padding">
<div id="sticky-bar" class=" unstick no-topbar">
<div class="row">
<div class="col-md-12">
<div id="sticky-inner" class="container-inner">
<div class="desktop-only"><div id="section-menu" class="mega-menu"><ul><li class="menu-item menu-item-485902 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485902" data-type="standard"><a class="parent-item  no-icon" href="/reviews"><span class="category-title">Reviews</span></a></li><li class="menu-item menu-item-485903 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485903" data-type="standard"><a class="parent-item  no-icon" href="/tag/editorial"><span class="category-title">Editorials</span></a></li><li class="menu-item menu-item-485904 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485904" data-type="standard"><a class="parent-item  no-icon" href="https://www.youtube.com/user/pocketnowvideo?sub_confirmation=1"><span class="category-title">Videos</span></a></li><li class="menu-item menu-item-485905 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485905" data-type="standard"><a class="parent-item  no-icon" href="/pocketnow-podcasts"><span class="category-title">Podcast</span></a></li><li class="menu-item menu-item-485906 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485906" data-type="standard"><a class="parent-item  no-icon" href="https://deals.pocketnow.com/deals/gear-gadgets?utm_source=pocketnow.com&utm_medium=navbar&utm_campaign=mobile-page#42-mobile"><span class="category-title">Deals</span></a></li><li class="menu-item menu-item-501887 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="501887" data-type="standard"><a class="parent-item  no-icon" href="https://www.youtube.com/channel/UCa5KZTc2GvIvNvEiJviraDw?sub_confirmation=1"><span class="category-title">Español</span></a></li><li class="menu-item menu-item-528150 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="528150" data-type="standard"><a class="parent-item  no-icon" target="_blank" rel="nofollow" href="https://swappa.com/?utm_campaign=pocketnow&utm_source=pocketnow&utm_medium=site&utm_content=navbar"><span class="category-title">Swappa <img src="/wp-content/themes/techwise-child/images/swappa_25x25_on_white.png" style="width:15px;"></span></a></li></ul></div></div><div class="section-toggle add-active"><span class="section-more-label">Navigation</span><span class="theme-icon-sort-down"></span></div><div class="section-menu-mobile"><ul><li class="menu-item menu-item-485902 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485902" data-type="standard"><a class="parent-item  no-icon" href="/reviews"><span class="category-title">Reviews</span></a></li><li class="menu-item menu-item-485903 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485903" data-type="standard"><a class="parent-item  no-icon" href="/tag/editorial"><span class="category-title">Editorials</span></a></li><li class="menu-item menu-item-485904 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485904" data-type="standard"><a class="parent-item  no-icon" href="https://www.youtube.com/user/pocketnowvideo?sub_confirmation=1"><span class="category-title">Videos</span></a></li><li class="menu-item menu-item-485905 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485905" data-type="standard"><a class="parent-item  no-icon" href="/pocketnow-podcasts"><span class="category-title">Podcast</span></a></li><li class="menu-item menu-item-485906 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="485906" data-type="standard"><a class="parent-item  no-icon" href="https://deals.pocketnow.com/deals/gear-gadgets?utm_source=pocketnow.com&utm_medium=navbar&utm_campaign=mobile-page#42-mobile"><span class="category-title">Deals</span></a></li><li class="menu-item menu-item-501887 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="501887" data-type="standard"><a class="parent-item  no-icon" href="https://www.youtube.com/channel/UCa5KZTc2GvIvNvEiJviraDw?sub_confirmation=1"><span class="category-title">Español</span></a></li><li class="menu-item menu-item-528150 custom  loaded" data-loop="menu" data-method="" data-object_name="" data-object="custom" data-objectid="528150" data-type="standard"><a class="parent-item  no-icon" target="_blank" rel="nofollow" href="https://swappa.com/?utm_campaign=pocketnow&utm_source=pocketnow&utm_medium=site&utm_content=navbar-mobile"><span class="category-title">Swappa <img src="/wp-content/themes/techwise-child/images/swappa_25x25_on_white.png" style="width:15px;"></span></a></li></ul></div>
<div id='mini-logo'>
<a href="https://pocketnow.com/">
<img id="site-logo" alt="Pocketnow" src="https://pocketnow.com/wp-content/uploads/2016/11/LogoX4.png" width="89" height="35" />
<img id="site-logo-hd" alt="Pocketnow" src="https://pocketnow.com/wp-content/uploads/2016/11/LogoX4.png" width="89" height="35" />
</a>
</div>
<div id="search-toggle" class="add-active" data-track data-track-props='{"action":"Clicked", "category":"Nav Search"}'><span class="theme-icon-search"></span></div>
<div id="sticky-search">
<form role="search" method="get" class="searchform" action="https://pocketnow.com/">
<input type="text" value="" name="s" placeholder="Type to search" />
</form>
<div class="triangle triangle-border"></div>
<div class="triangle"></div>
</div>
</div>
</div>
</div>
</div>
<section class="below-nav-ad" style="display: none;">
<p>Hate ads? Download <a href="https://forum.xda-developers.com/getbrave">Brave web browser</a>. Fast, secure, built in ad-blocking.</p>
</section>
<script>

function getCookieValue(name)
{
    var re = new RegExp(name + "=([^;]+)");
    var value = re.exec(document.cookie);
    return (value != null) ? unescape(value[1]) : null;
}

function sponsorView(client, adId) {
    if (typeof gtag !== 'undefined') {
        gtag('event', 'View', {
          'event_category' : client,
          'event_label' : adId,
          'non_interaction': true
        });
    }
    if (typeof ga !== 'undefined') {
        ga('send', 'event', client, 'View', adId, {
            nonInteraction: true
        });
    }
}

function sponsorClick(client, adId) {
    if (typeof gtag !== 'undefined') {
        gtag('event', 'Click', {
          'event_category' : client,
          'event_label' : adId
        });
    }
    if (typeof ga !== 'undefined') {
        ga('send', 'event', client, 'Click', adId);
    }
}

      function showBraveTwig() {
              let braveTwig = document.getElementsByClassName('below-nav-ad')[0];
                  if (braveTwig) {

                              braveTwig.addEventListener("click", function () {
            sponsorClick("Brave", "BraveTwigPocketnow")
        });
                              braveTwig.style.display = 'flex';
                    // SendViw
                    sponsorView('Brave', 'BraveTwigPocketnow');
                }
      }


  let show_bravetwig = (function()
{

            let shownTwig = parseInt(getCookieValue('brave_twig_shown'));
            if (!shownTwig) {
                // set shown to 1, return false
                // Set 1X24 detection
                let d = new Date();
                d.setHours(d.getHours() + 24);
                document.cookie = "brave_twig_shown=1; expires=" + d.toUTCString() + "; path=/";
                //return true;
                showBraveTwig();
            } else if (shownTwig === 1) {
                let d = new Date();
                d.setHours(d.getHours() + 24);
                document.cookie = "brave_twig_shown=; expires=Thu, 01 Jan 1970 00:00:00 UTC; path=/;"; // delete old cookie
                document.cookie = "brave_twig_shown="+(shownTwig+1)+"; expires=" + d.toUTCString() + "; path=/"; // set new cookie
                showBraveTwig();
                //return true;
            } else {
                // do nothing
                //return false;
            }
})();


</script>
<div class="cta-bar cta-bar-podcast">
<a href="/pocketnow-podcasts" class="cta-bar-target" data-track data-track-props='{"category":"Podcast Subscribe", "action":"Click", "label":"Bar Below Nav Headshots"}'>
<div class="cta-bar-headshots">
<img src="/wp-content/themes/techwise-child/images/headshots/brandon-miniman.jpg" width="30" alt="Brandon Miniman">
<img src="/wp-content/themes/techwise-child/images/headshots/jaime-rivera.jpg" width="30" alt="Jaime Rivera">
<img src="/wp-content/themes/techwise-child/images/headshots/joshua-vergara.jpg" width="30" alt="Joshua Vergara">
</div>
<div class="cta-bar-main">
<p>Listen to the <i class="cta-bar-highlight-word">NEW</i> Pocketnow Weekly</p>
</div>
<img src="/wp-content/themes/techwise-child/images/icons/arrow-right.svg" class="cta-bar-icon" alt="Go">
</a>
</div>
</div>
<div class="after-header no-topbar">
<div class="container-fluid no-padding single-wrapper sidebar-right post-546172 post type-post status-publish format-standard has-post-thumbnail hentry category-android category-ios category-phones tag-background-blur tag-depth-map tag-editorial tag-iphone tag-photoshop tag-portrait-mode" data-location="single-page" itemscope itemtype="http://schema.org/Article">
<div itemtype="http://schema.org/Organization" itemprop="publisher" itemscope>
<div itemprop="logo" itemtype="http://schema.org/ImageObject" itemscope>
<meta itemprop="url" content="https://pocketnow.com/wp-content/uploads/2016/11/LogoX4.png" />
</div>
<meta itemprop="name" content="Pocketnow" />
<meta itemprop="url" content="https://pocketnow.com/" />
</div>
<meta itemprop="mainEntityOfPage" content="https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode" />
<div class="row">
<div class="col-md-12">
<div class="container-inner single-content-wrapper classic-post">
<div class="row">
<div class="col-md-9 single-post-selector">
<div class="single-page   category-15">
<div id="post-546172" class="post-content post-selector" data-postid="546172">
<div class="control-bar clearfix">
<div class="control-category">
<div class="circled-icon category-15"><span class="category-icon category-icon-15-20"></span></div>
<a class="category-link" href="https://pocketnow.com/category/android">Android</a>
</div>
 <div class="trending-toggle add-active popover-meta" data-placement="bottom" data-content="Trending" data-postid="546172">
<span class="meta-heat metric heat-index" title="Heat Index"><span class="icon theme-icon-flame"></span></span>
</div>
</div>
<h1 class="padded-panel main-title single-title entry-title" itemprop="headline">How to fix your phone&#8217;s shitty portrait mode</h1>
<div class="padded-panel share-bar clearfix">
<div class="addthis_toolbox addthis_inline_share_toolbox addthis_default_style addthis_32x32_style" data-title="How to fix your phone&#8217;s shitty portrait mode" data-url="https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode" addthis:description="Ever since Apple introduced their depth map generated fake background blur filter known as Portrait mode, practically all other phone makes have also added that feature.  In all cases it&#039;s terrible at making your photos &hellip;"></div>
<div class="authorship type-both"><span class="author vcard">by&nbsp;<a class="styled" href="https://pocketnow.com/author/adamlein" itemprop="author" itemscope itemtype="http://schema.org/Person"><span class="fn" itemprop="name">Adam Z. Lein</span></a></span><span class="date updated">July 24, 2019 8:00 am</span><meta itemprop="datePublished" content="2019-07-24T08:00:02-04:00" />
<meta itemprop="dateModified" content="2019-07-24T09:21:41-04:00" />
</div>
<span class="meta-comments metric" title="Comments">
<span class="icon theme-icon-commented"></span>
<span class="labeltext disqus-comment-count" data-disqus-identifier="pocketnow_546172"></span>
</span>
</div>
<div class="post-left fixed-object">
<div class="post-left-toggle add-active"><span class="theme-icon-bookmark"></span><span class="theme-icon-right-open"></span><span class="theme-icon-left-open"></span></div>

<div class="contents-menu"><div class="contents-title">Contents</div><ul class="contents-links nav"><li id="content-anchor-wrapper"><a href="#content-anchor">Full Article</a></li><li id="rating-anchor-wrapper"><a href="#rating-anchor">Rating</a></li><li id="comments-anchor-wrapper"><a href="#comments">Comments</a></li></ul></div>
</div>
<div class="post-right content-panel">
<div class="widget-block">
</div>
<div class="image-container"> <div class="featured-image-wrapper">
<div class="featured-image-inner" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
<meta itemprop="url" content="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage.jpg">
<meta itemprop="width" content="800">
<meta itemprop="height" content="600"><img width="780" height="585" src="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage.jpg" class=" wp-post-image" alt="" title="How to fix your phone&#8217;s shitty portrait mode" itemprop="image" srcset="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-641x481.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-768x576.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-20x15.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-40x30.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-80x60.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></div></div></div><div class="the-content padded-panel"><div id="content-anchor"></div><div id="content-anchor-inner" class="clearfix"><p>Ever since Apple introduced their depth map generated fake background blur filter known as Portrait mode, practically all other phone makes have also added that feature.  In all cases it&#8217;s terrible at making your photos look good because the filters never get the edge details right.  They&#8217;re always either over masked or under masked and it always looks like a it was made by a high school Photoshop student who only took the class because they thought it was an easy A and didn&#8217;t really care about quality.  I had always wished that I could get that actual depth map out of these phone cameras and fix it up in Photoshop in order to make an actually good image.</p><div class="widget-block">
</div>
<div id="attachment_546194" style="width: 790px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-546194" class="size-full wp-image-546194" src="https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323_blurred_780px.jpg" alt="" width="780" height="583" srcset="https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323_blurred_780px.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323_blurred_780px-641x479.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323_blurred_780px-768x574.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323_blurred_780px-20x15.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323_blurred_780px-40x30.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323_blurred_780px-80x60.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /><p id="caption-attachment-546194" class="wp-caption-text">Here&#8217;s what the image from the phone looks like.</p></div>
<p>In this tutorial, we&#8217;re going to look at a technique for fixing the depth map generated by a Nokia 9 Pureview phone using Adobe Photoshop. You can probably translate these techniques to other phone cameras and photo editing programs like GIMP, Krita, Affinity Photo, etc.</p>
<h2>Extract the depth map</h2>
<p>The logical method of saving the depth map with the photo would have been to include it either as an Alpha channel or as a separate file. In the early days of video compositing with transparency masks, that&#8217;s what we always did.  That&#8217;s not how any of these cameras work though.  Instead we have to use a special tool to extract the depth map.</p>
<p>There&#8217;s a free web-based tool at <a target="_blank" href="https://www.omnivirt.com/3d-photo/" target="_blank" rel="noopener noreferrer nofollow">https://www.omnivirt.com/3d-photo/</a> which will do it. Now, the depth map information is usually saved within the JPG on many Android devices&#8230; not the DNG file like one would hope.</p>
<p>We&#8217;re going to use a photo from the Nokia 9 Pureview since its 5 cameras should give us a pretty good starting point for the depth map.</p>
<p><img class="aligncenter size-full wp-image-546173" src="https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_780px.jpg" alt="" width="780" height="573" srcset="https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_780px.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_780px-641x471.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_780px-768x564.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_780px-20x15.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_780px-40x29.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_780px-80x59.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>First, upload your photo to the Omnivirt 3D photo creator tool.</p>
<p><img class="aligncenter size-full wp-image-546174" src="https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_2_780px.jpg" alt="" width="780" height="573" srcset="https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_2_780px.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_2_780px-641x471.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_2_780px-768x564.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_2_780px-20x15.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_2_780px-40x29.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/3Dphotocreator_2_780px-80x59.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>Then download the ZIP file and extract it to a folder.</p>
<p><img class="aligncenter size-full wp-image-546175" src="https://pocketnow.com/wp-content/uploads/2019/07/image_depth_780px.jpg" alt="" width="780" height="583" srcset="https://pocketnow.com/wp-content/uploads/2019/07/image_depth_780px.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/image_depth_780px-641x479.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/image_depth_780px-768x574.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/image_depth_780px-20x15.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/image_depth_780px-40x30.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/image_depth_780px-80x60.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>The file called &#8220;image_depth.jpg&#8221; is the one that includes the extracted depth map. It will look something like the above.  The lighter shades of grey indicate pixels that are closer to the camera while the darker shades specify pixel areas that are further away. And as you can see&#8230; this depth map is an awful mess.</p>
<h2>Bring everything into Photoshop</h2>
<p><img class="aligncenter size-full wp-image-546176" src="https://pocketnow.com/wp-content/uploads/2019/07/AdobeCameraRaw_dng.jpg" alt="" width="780" height="565" srcset="https://pocketnow.com/wp-content/uploads/2019/07/AdobeCameraRaw_dng.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/AdobeCameraRaw_dng-641x464.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/AdobeCameraRaw_dng-768x556.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/AdobeCameraRaw_dng-20x14.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/AdobeCameraRaw_dng-40x29.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/AdobeCameraRaw_dng-80x58.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>Now, instead of applying that depth map to the phone-processed JPG, I&#8217;m going to open the RAW DNG file in Photoshop.  Yes, the Nokia 9 Pureview RAW files are also already hardware-processed to merge the 5 camera photos into one, but it&#8217;s still better than using the JPG and we&#8217;ll be able to make a much more flexible non-destructive layered image file. The Nokia 9 Pureview is able to save both a processed JPG along with the RAW DNG file, so that feature helps a lot here as well. Don&#8217;t forget to hold down &#8220;Shift&#8221; in the Adobe Camera Raw dialog in order to open the DNG file as a Smart Object.</p>
<p><img class="aligncenter wp-image-546178 size-full" src="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_1-1.jpg" alt="" width="780" height="374" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_1-1.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_1-1-641x307.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_1-1-768x368.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_1-1-20x10.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_1-1-40x19.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_1-1-80x38.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>Next I&#8217;m going to create a new Alpha channel in that DNG file and Copy/Paste the image_depth.jpg into that Alpha channel. Then we should probably do File &gt; Save As &gt; and make a new PSD file to preserve everything.</p>
<p><img class="aligncenter size-full wp-image-546179" src="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_2.jpg" alt="" width="571" height="475" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_2.jpg 571w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_2-20x17.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_2-40x33.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_2-80x67.jpg 80w" sizes="(max-width: 571px) 100vw, 571px" /></p>
<p>Next I&#8217;m going to make a copy of the image layer by dragging it to the new layer icon in the Layers palette, then I&#8217;ll load that Alpha channel as a selection by Ctrl + clicking on it. Then select the image layer copy and choose Layer &gt; Layer Mask &gt; Reveal selection to create a layer mask.  This top layer will be our in-focus layer.</p>
<p><img class="aligncenter size-full wp-image-546180" src="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_3.jpg" alt="" width="780" height="505" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_3.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_3-641x415.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_3-768x497.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_3-20x13.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_3-40x26.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_3-80x52.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>Next, Alt/Opt click on the layer mask that we just created in the Layers palette. This will let you see the greyscale levels of the layer mask.  The white areas are the things closest to the camera while the black areas are the furthest away.  I&#8217;m going to use this to make my subject remain sharp and unmodified while letting the far away areas be blurred by a filter.  Now, you&#8217;ll notice that my model&#8217;s face is 87% black in this depth map.  That&#8217;s way too much!</p>
<p><img class="aligncenter size-full wp-image-546181" src="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_4.jpg" alt="" width="780" height="521" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_4.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_4-641x428.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_4-768x513.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_4-20x13.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_4-40x27.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_4-80x53.jpg 80w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_4-320x215.jpg 320w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>So I&#8217;m going to hit Ctrl + M and use the white eye dropper to click on her forehead in order to make the model&#8217;s mask area white and therefore opaque. You can see this causes a lot of banding between the depth levels because our depth map does not have much range or resolution.</p>
<p><img class="aligncenter size-full wp-image-546182" src="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_5.jpg" alt="" width="780" height="433" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_5.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_5-641x356.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_5-768x426.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_5-20x11.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_5-40x22.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_5-80x44.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>Now I&#8217;m going to apply a Gaussian Blur filter to the bottom image layer and we&#8217;ve got almost the same thing that the phone&#8217;s background blur filter would have done.  It&#8217;s a terrible mess!!</p>
<h2>Now you can control it</h2>
<p>All of that work to get something that looks just as bad as what the camera phone did automatically may seem like a wast of time, but NOW we have that Photoshop file set up so that we can actually control things with a lot more flexibility.  So next you&#8217;ll want to get your painting tools ready because we&#8217;re going to fix that depth map manually.</p>
<p><img class="aligncenter size-full wp-image-546185" src="https://pocketnow.com/wp-content/uploads/2019/07/WacomPhotoshop_IMG_20190723_103658.jpg" alt="" width="780" height="585" srcset="https://pocketnow.com/wp-content/uploads/2019/07/WacomPhotoshop_IMG_20190723_103658.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/WacomPhotoshop_IMG_20190723_103658-641x481.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/WacomPhotoshop_IMG_20190723_103658-768x576.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/WacomPhotoshop_IMG_20190723_103658-20x15.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/WacomPhotoshop_IMG_20190723_103658-40x30.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/WacomPhotoshop_IMG_20190723_103658-80x60.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>This is where you need a bit of skill and you&#8217;ll probably need to change your technique depending on what kind of image you&#8217;re working with.  Basically, you need to use painting tools with varying levels of black, white, and grey to edit the layer mask until it looks right. There are tons of different techniques you could use here as well. You can use a pressure sensitive pen to simply paint away the ugly areas, or you can use some of the color channels from the original image to create selections or sub-masks and use those to paint away the ugly areas&#8230; the possibilities are endless. It&#8217;s difficult to tell you exactly what to do here since there are so many options.</p>
<p>For this image, I mainly used the pressure-sensitive pen method.  Use the [ ] bracket keys to change the brush&#8217;s diameter as you go.  Use the X key to switch between black and white paint colors as you modify the mask.  Use the number keys to quickly change the flow of an airbrush or opacity of a paintbrush.</p>
<p><img class="aligncenter wp-image-546190 size-full" src="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterMask.jpg" alt="" width="780" height="624" srcset="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterMask.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterMask-641x513.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterMask-768x614.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterMask-20x16.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterMask-40x32.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterMask-80x64.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>How much effort you put into fixing the depth map mask again depends on you and what kind of image you&#8217;re using.  Above is what I ended up with.  It&#8217;s not perfect, but it should do fine. Note that I added a gradient blend on the floor area so that the ground level closest to the model would evenly stay sharp. A lot of depth maps generated in phone cameras don&#8217;t get that right.</p>
<h2>Using the good depth map</h2>
<p>The above technique for using a sharp masked copy of the image on top of a blurred copy of the image was mainly meant for editing the mask in order to get a decent depth map.  That technique isn&#8217;t quite right for the final image because the transparency masking on top blends with the blurred image on the bottom and blurred edges bleed out around the sides.  Really, we want to use the new depth map to apply a Lens blur gradually in different areas.</p>
<p>Copy the grey-scale final layer mask into a new Alpha channel.  You can do this by loading it as a selection and then making a new Alpha channel from the selection.  Mine is called &#8220;Alpha 4&#8221;.</p>
<p><img class="aligncenter size-full wp-image-546191" src="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_LensBlur.jpg" alt="" width="780" height="579" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_LensBlur.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_LensBlur-641x476.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_LensBlur-768x570.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_LensBlur-20x15.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_LensBlur-40x30.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Photoshop_LensBlur-80x59.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /></p>
<p>What I did next was create a copy of the original DNG Smart object layer, then right click it and choose &#8220;Rasterize&#8221;.  This removes the non-destructive properties for that layer and this is necessary for the &#8220;Lens blur&#8221; filter to work.  Next, I chose Filter &gt; Blur &gt; Lens blur which brings up the above filter dialog.  The important part here is that you choose your final edited depth map alpha channel in the Depth Map &gt; &#8220;Source&#8221; drop down menu.  It may be that the filter applies to the subject instead of the background if you used whites to reveal the subject in your alpha channel.  If this is the case, click the &#8220;invert&#8221; checkbox in the Lens Blur filter to apply the filter to the opposite areas.  Adjust the other sliders, especially the &#8220;radius&#8221; one, as you see fit and click OK to apply.</p>
<p>That&#8217;s it!  Now you have a much better fake background blur filter!</p>
<div id="attachment_546195" style="width: 790px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-546195" class="size-full wp-image-546195" src="https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323-1c_780px.jpg" alt="" width="780" height="583" srcset="https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323-1c_780px.jpg 780w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323-1c_780px-641x479.jpg 641w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323-1c_780px-768x574.jpg 768w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323-1c_780px-20x15.jpg 20w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323-1c_780px-40x30.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/IMG_20190316_145323-1c_780px-80x60.jpg 80w" sizes="(max-width: 780px) 100vw, 780px" /><p id="caption-attachment-546195" class="wp-caption-text">Here&#8217;s what the final image looks like.</p></div>
<p>&nbsp;</p>
<p style="text-align: center;"><em>Guest appearance by <a target="_blank" href="http://dariamudrova.com" target="_blank" rel="noopener noreferrer nofollow">Dasha Mudrova</a>.</em></p>
<p class="m0"><div class="load-comments-link" data-load-comments>Discuss This Post</div></p>
<div id="comments"></div>
<div id="disqus_thread"></div></div></div><ul class="prevnext"><li class="prevnext-item prev"><a href="https://pocketnow.com/iphone-accessory-bundles-deal" rel="prev">Next Article</a></li></ul><style type="text/css"> #rating-anchor-wrapper {display:none;} </style><div class="widget-block">
<div class="textwidget custom-html-widget"><div class="ac">
<i>Share This Post</i>
<div class="addthis_toolbox addthis_inline_share_toolbox addthis_default_style addthis_32x32_style" data-title="How to fix your phone&#8217;s shitty portrait mode" data-url="https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode" addthis:description="Ever since Apple introduced their depth map generated fake background blur filter known as Portrait mode, practically all other phone makes have also added that feature.  In all cases it&#039;s terrible at making your photos &hellip;"></div>
</div>
</div> </div>
<section id="youtube-mobile-container" class="youtube-section">
<h3 class="youtube-mobile-heading">Watch the Latest Pocketnow Videos</h3>
<div class="youtube-mobile-list"></div>
</section><div class="big-like clearfix"></div><div class="postinfo"><div class="row hidden"><div class="col-xs-12 post-source"></div></div><div class="row"><div class="col-xs-6 post-categories"><div class="meta-label">Posted In</div><div class="category-list"><a href="https://pocketnow.com/category/android" title="View all posts in Android">Android</a>, <a href="https://pocketnow.com/category/ios" title="View all posts in iOS">iOS</a>, <a href="https://pocketnow.com/category/phones" title="View all posts in Phones">Phones</a></div></div><div class="col-xs-6 post-tags"><div class="meta-label">Tags</div><div class="tag-list"><a href="https://pocketnow.com/tag/background-blur" title="Background blur Tag" class="background-blur">Background blur</a>, <a href="https://pocketnow.com/tag/depth-map" title="Depth Map Tag" class="depth-map">Depth Map</a>, <a href="https://pocketnow.com/tag/editorial" title="Editorial Tag" class="editorial">Editorial</a>, <a href="https://pocketnow.com/tag/iphone" title="iPhone Tag" class="iphone">iPhone</a>, <a href="https://pocketnow.com/tag/photoshop" title="Photoshop Tag" class="photoshop">Photoshop</a>, <a href="https://pocketnow.com/tag/portrait-mode" title="Portrait Mode Tag" class="portrait-mode">Portrait Mode</a></div><div class="hidden-tags"><a href="https://pocketnow.com/tag/background-blur" rel="tag">Background blur</a>, <a href="https://pocketnow.com/tag/depth-map" rel="tag">Depth Map</a>, <a href="https://pocketnow.com/tag/editorial" rel="tag">Editorial</a>, <a href="https://pocketnow.com/tag/iphone" rel="tag">iPhone</a>, <a href="https://pocketnow.com/tag/photoshop" rel="tag">Photoshop</a>, <a href="https://pocketnow.com/tag/portrait-mode" rel="tag">Portrait Mode</a></div></div></div></div><div class="authorinfo"><div class="author-info clearfix"><div class="meta-label">About The Author</div><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://pocketnow.com/author/adamlein"><img width="70" height="70" src="https://pocketnow.com/wp-content/uploads/2012/07/Adam-70x70.jpg" class="avatar avatar-70 photo" alt="" srcset="https://pocketnow.com/wp-content/uploads/2012/07/Adam-70x70.jpg 70w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-32x32.jpg 32w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-64x64.jpg 64w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-26x26.jpg 26w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-18x18.jpg 18w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-140x140.jpg 140w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-128x128.jpg 128w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-52x52.jpg 52w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-36x36.jpg 36w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2012/07/Adam-50x50.jpg 50w, https://pocketnow.com/wp-content/uploads/2012/07/Adam.jpg 150w" sizes="(max-width: 70px) 100vw, 70px" /></a></div><a class="info author-name" title="See all posts from this author" href="https://pocketnow.com/author/adamlein">Adam Z. Lein</a><div class="author-bio">Adam has had interests in combining technology with art since his first use of a Koala pad on an Apple computer. He currently has a day job as a graphic designer, photographer, systems administrator and web developer at a small design firm in Westchester, NY. His love of technology extends to software development companies who have often implemented his ideas for usability and feature enhancements. Mobile computing has become a necessity for Adam since his first Uniden UniPro PC100 in 1998. He has been reviewing and writing about smartphones for Pocketnow.com since they first appeared on the market in 2002. <a href="https://pocketnow.com/2013/06/01/get-to-know-adam-lein">Read more about Adam Lein!</a></div><div class="author-profile-fields"><a class="theme-icon-twitter info" title="Find me on Twitter" href="https://twitter.com/adamzea" target="_blank" rel="nofollow"></a><a class="theme-icon-email info" title="E-mail Me" href="/cdn-cgi/l/email-protection#e68782878b9ca69689858d8392888991c885898b" rel="nofollow"></a></div></div></div><div class="widget-block">
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
   var disqus_shortname = 'pocketnow'; // required: replace example with your forum shortname
   var disqus_identifier = 'pocketnow_546172';
   var disqus_url = "https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode";
  </script>
<div id="rcjsload_24061c"></div><div class="widget-block">
<div class="textwidget custom-html-widget">
</div> </div>
</div>
</div>
</div>
</div>
<div class="col-md-3 single-sidebar-selector clearfix">
<div class="content-panel fixed-object single-sidebar">
<div class="widgets-wrapper"><div class="widgets clearfix "><div id="it_list_paged-1" class="widget clearfix"><div id='widgets-list' class='post-container widget-panel compact-header widget_a' data-currentquery='[]'><div class="bar-header sortbar clearfix"><div class="label-text">Recent Posts</div><div class="metric-text"></div></div><div class="content-inner clearfix"><div class="loading load-sort"><span class="theme-icon-spin2"></span></div><div class="loop"><div class="compact-panel add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="60" height="60" src="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-60x60.jpg" class=" wp-post-image" alt="" title="How to fix your phone&#8217;s shitty portrait mode" srcset="https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-150x150.jpg 150w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-300x300.jpg 300w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-266x266.jpg 266w, https://pocketnow.com/wp-content/uploads/2019/07/BeforeAfterimage-600x585.jpg 600w" sizes="(max-width: 60px) 100vw, 60px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/how-to-fix-your-phones-shitty-portrait-mode">How to fix your phone&#8217;s shitty portrait mode</a></div></div></div><div class="compact-panel add-active clearfix category-10838 no-rating"><div class="article-image-wrapper"><img width="60" height="60" src="https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-60x60.jpg" class=" wp-post-image" alt="" title="Equip your iPhone with the ultimate accessories for 66% off the original price" srcset="https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-150x150.jpg 150w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-300x300.jpg 300w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-266x266.jpg 266w" sizes="(max-width: 60px) 100vw, 60px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/iphone-accessory-bundles-deal">Equip your iPhone with the ultimate accessories for 66% off the original price</a></div></div></div><div class="compact-panel add-active clearfix category-17 no-rating"><div class="article-image-wrapper"><img width="60" height="60" src="https://pocketnow.com/wp-content/uploads/2018/09/apple-iphone-xs-max-full-frontals-60x60.jpg" class=" wp-post-image" alt="" title="LG to supply Apple with flexible OLED panels for the 2020 iPhones" srcset="https://pocketnow.com/wp-content/uploads/2018/09/apple-iphone-xs-max-full-frontals-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2018/09/apple-iphone-xs-max-full-frontals-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2018/09/apple-iphone-xs-max-full-frontals-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2018/09/apple-iphone-xs-max-full-frontals-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2018/09/apple-iphone-xs-max-full-frontals-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2018/09/apple-iphone-xs-max-full-frontals-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2018/09/apple-iphone-xs-max-full-frontals-266x266.jpg 266w" sizes="(max-width: 60px) 100vw, 60px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/lg-to-supply-apple-with-flexible-oled-panels-for-the-2020-iphones">LG to supply Apple with flexible OLED panels for the 2020 iPhones</a></div></div></div><div class="compact-panel add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="60" height="60" src="https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-60x60.jpg" class=" wp-post-image" alt="" title="Galaxy Note10+, Galaxy Note10 to feature faster Snapdragon 855 Plus chip" srcset="https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-150x150.jpg 150w, https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-300x300.jpg 300w, https://pocketnow.com/wp-content/uploads/2019/07/official-Galaxy-Note10-renders-1-266x266.jpg 266w" sizes="(max-width: 60px) 100vw, 60px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/galaxy-note10-galaxy-note10-to-feature-faster-snapdragon-855-plus-chip">Galaxy Note10+, Galaxy Note10 to feature faster Snapdragon 855 Plus chip</a></div></div></div></div></div></div></div>
<div id="it_list_paged-12" class="widget clearfix"><div id='widgets-list' class='post-container widget-panel compact-header widget_a' data-currentquery='{"tag__in":["3140"]}'><div class="bar-header sortbar clearfix"><div class="label-text">Recent Deals</div><div class="metric-text"></div></div><div class="content-inner clearfix"><div class="loading load-sort"><span class="theme-icon-spin2"></span></div><div class="loop"><div class="compact-panel add-active clearfix category-10838 no-rating"><div class="article-image-wrapper"><img width="60" height="60" src="https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-60x60.jpg" class=" wp-post-image" alt="" title="Equip your iPhone with the ultimate accessories for 66% off the original price" srcset="https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-150x150.jpg 150w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-300x300.jpg 300w, https://pocketnow.com/wp-content/uploads/2019/07/iPhone-Accessory-Bundles-266x266.jpg 266w" sizes="(max-width: 60px) 100vw, 60px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/iphone-accessory-bundles-deal">Equip your iPhone with the ultimate accessories for 66% off the original price</a></div></div></div><div class="compact-panel add-active clearfix category-10838 no-rating"><div class="article-image-wrapper"><img width="60" height="60" src="https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-60x60.jpg" class=" wp-post-image" alt="" title="This portable gimbal is perfect for capturing 4K footage &#8212; now under $350" srcset="https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-150x150.jpg 150w, https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-300x300.jpg 300w, https://pocketnow.com/wp-content/uploads/2019/07/DJI-Osmo-Pocket-266x266.jpg 266w" sizes="(max-width: 60px) 100vw, 60px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/dji-osmo-pocket-deal">This portable gimbal is perfect for capturing 4K footage &#8212; now under $350</a></div></div></div><div class="compact-panel add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="60" height="60" src="https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-60x60.jpg" class=" wp-post-image" alt="" title="49% off this award-winning, quad-core Android tablet" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-150x150.jpg 150w, https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-300x300.jpg 300w, https://pocketnow.com/wp-content/uploads/2019/07/Asus-ZenPad-266x266.jpg 266w" sizes="(max-width: 60px) 100vw, 60px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/asus-zenpad-deal">49% off this award-winning, quad-core Android tablet</a></div></div></div><div class="compact-panel add-active clearfix category-10838 no-rating"><div class="article-image-wrapper"><img width="60" height="60" src="https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-60x60.jpg" class=" wp-post-image" alt="" title="Charging cable with built-in portable battery for under $20" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-150x150.jpg 150w, https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-300x300.jpg 300w, https://pocketnow.com/wp-content/uploads/2019/07/Nomad-Battery-Lightning-Cable-266x266.jpg 266w" sizes="(max-width: 60px) 100vw, 60px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/battery-lightning-cable-deal">Charging cable with built-in portable battery for under $20</a></div></div></div></div></div></div></div>
<div id="text-18" class="widget clearfix"><div class="bar-header"><div class="bar-label"><div class="label-text">Latest Videos</div></div></div> <div class="textwidget"><center>This Phone is ALMOST EVERYTHING You Need!
<script>
     function onYouTubeIframeAPIReady() {
        executeYouTubeQueue();
     }
     function executeYouTubeQueue() {
       window.ytPlayQueue = window.ytPlayQueue || [];
       while(window.ytPlayQueue.length > 0) {
         var v = window.ytPlayQueue.shift();
         var p = new YT.Player(v.domId, {
          height: v.height,
          width: v.width,
          videoId: v.ytId,
          events: {
            'onReady': function(evt)  { evt.target.playVideo(); }
          }
        });
       }
     }
     </script> <script>
       function loadYouTube_1() {
        window.ytPlayQueue = window.ytPlayQueue || [];
        window.ytPlayQueue.push({ domId: "youtube-preview-1",
                                  ytId: "L19SK-H6J2s",
                                  width: 290,
                                  height: 163 });
        if(window.YT) {
          executeYouTubeQueue();
        } else {
          var tag = document.createElement('script');
          tag.src = "https://www.youtube.com/iframe_api";
          document.body.appendChild(tag);
        }
      }
    </script>
<a class="youtube-preview" style="width: 290px; height: 163px" id="youtube-preview-1" width="290" height="163" youtube-id="L19SK-H6J2s" href="https://www.youtube.com/watch?v=L19SK-H6J2s" target="_blank" onclick="loadYouTube_1(); return false;" rel="noopener noreferrer">
<div class="preview" style="width: 290px; height: 163px; background-image: url('https://i.ytimg.com/vi/L19SK-H6J2s/hqdefault.jpg'); "></div>
<div class="play"></div>
</a>
<hr />
OnePlus 7 Pro vs Samsung Galaxy S10+ | Flagship Killed?
<script>
       function loadYouTube_2() {
        window.ytPlayQueue = window.ytPlayQueue || [];
        window.ytPlayQueue.push({ domId: "youtube-preview-2",
                                  ytId: "IPr7AsagkBk",
                                  width: 290,
                                  height: 163 });
        if(window.YT) {
          executeYouTubeQueue();
        } else {
          var tag = document.createElement('script');
          tag.src = "https://www.youtube.com/iframe_api";
          document.body.appendChild(tag);
        }
      }
    </script>
<a class="youtube-preview" style="width: 290px; height: 163px" id="youtube-preview-2" width="290" height="163" youtube-id="IPr7AsagkBk" href="https://www.youtube.com/watch?v=IPr7AsagkBk" target="_blank" onclick="loadYouTube_2(); return false;" rel="noopener noreferrer">
<div class="preview" style="width: 290px; height: 163px; background-image: url('https://i.ytimg.com/vi/IPr7AsagkBk/hqdefault.jpg'); "></div>
<div class="play"></div>
</a>
<hr />
What a REAL 5G experience is actually like!
<script>
       function loadYouTube_3() {
        window.ytPlayQueue = window.ytPlayQueue || [];
        window.ytPlayQueue.push({ domId: "youtube-preview-3",
                                  ytId: "qkGbm2OFESo",
                                  width: 290,
                                  height: 163 });
        if(window.YT) {
          executeYouTubeQueue();
        } else {
          var tag = document.createElement('script');
          tag.src = "https://www.youtube.com/iframe_api";
          document.body.appendChild(tag);
        }
      }
    </script>
<a class="youtube-preview" style="width: 290px; height: 163px" id="youtube-preview-3" width="290" height="163" youtube-id="qkGbm2OFESo" href="https://www.youtube.com/watch?v=qkGbm2OFESo" target="_blank" onclick="loadYouTube_3(); return false;" rel="noopener noreferrer">
<div class="preview" style="width: 290px; height: 163px; background-image: url('https://i.ytimg.com/vi/qkGbm2OFESo/hqdefault.jpg'); "></div>
<div class="play"></div>
</a>
<hr />
OnePlus 7 Pro vs iPhone XS Max: Fair Fight?
<script>
       function loadYouTube_4() {
        window.ytPlayQueue = window.ytPlayQueue || [];
        window.ytPlayQueue.push({ domId: "youtube-preview-4",
                                  ytId: "Gr8CWkkNUyI",
                                  width: 290,
                                  height: 163 });
        if(window.YT) {
          executeYouTubeQueue();
        } else {
          var tag = document.createElement('script');
          tag.src = "https://www.youtube.com/iframe_api";
          document.body.appendChild(tag);
        }
      }
    </script>
<a class="youtube-preview" style="width: 290px; height: 163px" id="youtube-preview-4" width="290" height="163" youtube-id="Gr8CWkkNUyI" href="https://www.youtube.com/watch?v=Gr8CWkkNUyI" target="_blank" onclick="loadYouTube_4(); return false;" rel="noopener noreferrer">
<div class="preview" style="width: 290px; height: 163px; background-image: url('https://i.ytimg.com/vi/Gr8CWkkNUyI/hqdefault.jpg'); "></div>
<div class="play"></div>
</a></center></div>
</div><div id="it_follow_us-1" class="widget clearfix"><div class="widget-panel widget-follow-us"><div class="bar-header"><div class="bar-label"><div class="label-text">Connect with Pocketnow</div></div></div><div class="social-badges clearfix"><a href="https://youtube.com/pocketnow" class="styled theme-icon-youtube" title="Subscribe to our YouTube channel" rel="nofollow" target="_blank"></a><a href="https://facebook.com/pocketnow" class="styled theme-icon-facebook" title="Like us on Facebook" rel="nofollow" target="_blank"></a><a href="https://twitter.com/pocketnow" class="styled theme-icon-twitter" title="Follow us on Twitter" rel="nofollow" target="_blank"></a><a href="https://plus.google.com/+pocketnow" class="styled theme-icon-googleplus" title="Follow us on Google+" rel="nofollow" target="_blank"></a><a href="https://instagram.com/pocketnow" class="styled theme-icon-instagram" title="Follow us on Instagram" rel="nofollow" target="_blank"></a></div></div></div>
</div></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="footer" class="container-fluid no-padding builder-section builder-widgets">
<div class="row">
<div class="col-md-12">
 <div class="container-inner">
<div class="row">
<div class="widget-panel left col-sm-3">
<div class="widgets-wrapper"><div class="widgets clearfix widgets"><div id="it_list_paged-9" class="widget clearfix"><div id='widgets-list' class='post-container widget-panel compact-header widget_b' data-currentquery='{"tag__in":["746"]}'><div class="bar-header sortbar clearfix"><div class="label-text">Recent Podcast Episodes</div><div class="metric-text"></div></div><div class="content-inner clearfix"><div class="loading load-sort"><span class="theme-icon-spin2"></span></div><div class="loop"><div class="compact-panel small add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2019/03/weekly349a-40x40.jpg" class=" wp-post-image" alt="" title="A history of failing: from Allo to RED | #PNWeekly 349" srcset="https://pocketnow.com/wp-content/uploads/2019/03/weekly349a-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/03/weekly349a-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/03/weekly349a-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/03/weekly349a-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/03/weekly349a-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/03/weekly349a-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/03/weekly349a-266x266.jpg 266w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/allo-red-pnweekly-349">A history of failing: from Allo to RED | #PNWeekly 349</a></div></div></div><div class="compact-panel small add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2019/03/weekly348-40x40.jpg" class=" wp-post-image" alt="" title="Huawei P30 Rumors! ft. Booredatwork | #PNWeekly 348" srcset="https://pocketnow.com/wp-content/uploads/2019/03/weekly348-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/03/weekly348-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/03/weekly348-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/03/weekly348-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/03/weekly348-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/03/weekly348-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/03/weekly348-266x266.jpg 266w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/huawei-p30-rumors-pnweekly-348">Huawei P30 Rumors! ft. Booredatwork | #PNWeekly 348</a></div></div></div><div class="compact-panel small add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2019/03/weekly347-40x40.jpg" class=" wp-post-image" alt="" title="Huawei Mate X: Late Techs or Latex? ft. Nicole Scott, Adam Conway | #PNWeekly 347" srcset="https://pocketnow.com/wp-content/uploads/2019/03/weekly347-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/03/weekly347-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/03/weekly347-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/03/weekly347-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/03/weekly347-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/03/weekly347-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/03/weekly347-266x266.jpg 266w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/huawei-mate-x-pnweekly-347">Huawei Mate X: Late Techs or Latex? ft. Nicole Scott, Adam Conway | #PNWeekly 347</a></div></div></div></div></div></div></div>
</div></div>
</div>
<div class="widget-panel mid mid-left col-sm-3">
<div class="widgets-wrapper"><div class="widgets clearfix widgets"><div id="it_list_paged-10" class="widget clearfix"><div id='widgets-list' class='post-container widget-panel compact-header widget_b' data-currentquery='{"tag__in":["1044"]}'><div class="bar-header sortbar clearfix"><div class="label-text">Recent Interviews</div><div class="metric-text"></div></div><div class="content-inner clearfix"><div class="loading load-sort"><span class="theme-icon-spin2"></span></div><div class="loop"><div class="compact-panel small add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2019/01/huawei-metal-logo-40x40.jpg" class=" wp-post-image" alt="" title="Huawei founder comments amidst tumult on security, US relationship" srcset="https://pocketnow.com/wp-content/uploads/2019/01/huawei-metal-logo-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/01/huawei-metal-logo-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/01/huawei-metal-logo-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/01/huawei-metal-logo-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/01/huawei-metal-logo-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/01/huawei-metal-logo-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/01/huawei-metal-logo-266x266.jpg 266w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/huawei-ren-zhengfei-comments">Huawei founder comments amidst tumult on security, US relationship</a></div></div></div><div class="compact-panel small add-active clearfix category-434 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2018/12/panos-panay-microsoft-40x40.jpg" class=" wp-post-image" alt="" title="Panay: Microsoft Surface hardware still going to be relevant" srcset="https://pocketnow.com/wp-content/uploads/2018/12/panos-panay-microsoft-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2018/12/panos-panay-microsoft-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2018/12/panos-panay-microsoft-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2018/12/panos-panay-microsoft-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2018/12/panos-panay-microsoft-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2018/12/panos-panay-microsoft-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2018/12/panos-panay-microsoft-e1545432835495-266x266.jpg 266w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/panay-microsoft-surface-hardware-still-going-to-be-relevant">Panay: Microsoft Surface hardware still going to be relevant</a></div></div></div><div class="compact-panel small add-active clearfix category-17 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2018/08/Qualcomm-40x40.jpeg" class=" wp-post-image" alt="5G" title="Qualcomm still positive on Apple relationship" srcset="https://pocketnow.com/wp-content/uploads/2018/08/Qualcomm-40x40.jpeg 40w, https://pocketnow.com/wp-content/uploads/2018/08/Qualcomm-266x266.jpeg 266w, https://pocketnow.com/wp-content/uploads/2018/08/Qualcomm-136x136.jpeg 136w, https://pocketnow.com/wp-content/uploads/2018/08/Qualcomm-60x60.jpeg 60w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/qualcomm-still-positive-on-apple-relationship">Qualcomm still positive on Apple relationship</a></div></div></div></div></div></div></div>
</div></div> 
</div>
<div class="widget-panel mid mid-right col-sm-3">
<div class="widgets-wrapper"><div class="widgets clearfix widgets"><div id="it_list_paged-11" class="widget clearfix"><div id='widgets-list' class='post-container widget-panel compact-header widget_b' data-currentquery='{"tag__in":["89"]}'><div class="bar-header sortbar clearfix"><div class="label-text">Recent Videos</div><div class="metric-text"></div></div><div class="content-inner clearfix"><div class="loading load-sort"><span class="theme-icon-spin2"></span></div><div class="loop"><div class="compact-panel small add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-40x40.jpg" class=" wp-post-image" alt="Honor 20 vs OnePlus 7" title="Honor 20 vs OnePlus 7: Simply similar (video)" srcset="https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-150x150.jpg 150w, https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-300x300.jpg 300w, https://pocketnow.com/wp-content/uploads/2019/07/Honor-20-vs-OnePlus-7-266x266.jpg 266w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/honor-20-vs-oneplus-7-video">Honor 20 vs OnePlus 7: Simply similar (video)</a></div></div></div><div class="compact-panel small add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2019/05/PGH51826-40x40.jpg" class=" wp-post-image" alt="Honor 20 Pro" title="Honor 20 Pro hands-on: beautiful uncertainty? (video)" srcset="https://pocketnow.com/wp-content/uploads/2019/05/PGH51826-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/05/PGH51826-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/05/PGH51826-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/05/PGH51826-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/05/PGH51826-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/05/PGH51826-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/05/PGH51826-266x266.jpg 266w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/honor-20-pro-hands-on">Honor 20 Pro hands-on: beautiful uncertainty? (video)</a></div></div></div><div class="compact-panel small add-active clearfix category-15 no-rating"><div class="article-image-wrapper"><img width="40" height="40" src="https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-40x40.jpg" class=" wp-post-image" alt="" title="Pocketnow Daily: Samsung Galaxy Fold Testing, iPhone XIR color variants leaked &#038; more (video)" srcset="https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-40x40.jpg 40w, https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-136x136.jpg 136w, https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-60x60.jpg 60w, https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-24x24.jpg 24w, https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-48x48.jpg 48w, https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-96x96.jpg 96w, https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-266x266.jpg 266w, https://pocketnow.com/wp-content/uploads/2019/04/GalaxyFold__AZL7625-600x585.jpg 600w" sizes="(max-width: 40px) 100vw, 40px" /></div><div class="article-info"><div class="article-title"><a class="styled" href="https://pocketnow.com/pocketnow-daily-samsung-galaxy-fold-testing-iphone-xir-color-variants-leaked-more-video">Pocketnow Daily: Samsung Galaxy Fold Testing, iPhone XIR color variants leaked &#038; more (video)</a></div></div></div></div></div></div></div>
</div></div>
</div>
<div class="widget-panel right col-sm-3">
<div class="widgets-wrapper"><div class="widgets clearfix widgets"><div id="nav_menu-2" class="widget clearfix"><div class="bar-header"><div class="bar-label"><div class="label-text">Get in touch</div></div></div><div class="menu-us-menu-container"><ul id="menu-us-menu" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-485907"><a href="https://pocketnow.com/about-us-pocketnow">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-485908"><a href="https://pocketnow.com/contact-us-pocketnow">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-485909"><a href="https://pocketnow.com/tip-us">Tip Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-494291"><a href="https://pocketnow.com/terms-and-conditions">Terms and Conditions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-494292"><a href="https://pocketnow.com/privacy-policy">Privacy Policy</a></li>
</ul></div></div><div id="it_follow_us-4" class="widget clearfix"><div class="widget-panel widget-follow-us"><div class="bar-header"><div class="bar-label"><div class="label-text">Follow Us</div></div></div><div class="social-badges clearfix"><a href="https://youtube.com/pocketnow" class="styled theme-icon-youtube" title="Subscribe to our YouTube channel" rel="nofollow" target="_blank"></a><a href="https://facebook.com/pocketnow" class="styled theme-icon-facebook" title="Like us on Facebook" rel="nofollow" target="_blank"></a><a href="https://twitter.com/pocketnow" class="styled theme-icon-twitter" title="Follow us on Twitter" rel="nofollow" target="_blank"></a><a href="https://plus.google.com/+pocketnow" class="styled theme-icon-googleplus" title="Follow us on Google+" rel="nofollow" target="_blank"></a><a href="https://instagram.com/pocketnow" class="styled theme-icon-instagram" title="Follow us on Instagram" rel="nofollow" target="_blank"></a></div></div></div>
</div></div>
</div>
</div>
<div class="subfooter">
<div class="row">
<div class="col-sm-6 copyright">
©2018 Pocketnow.com. All rights reserved - KC Online Media, LLC
</div>
<div class="col-sm-6 credits">
Pocketnow.com - Smartphone, Tablet, and Wearable reviews, videos, editorials, and news

</div>
</div>
</div>
</div> 
</div> 
</div> 
</div> 
</div> 
<style type="text/css">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</style><div class="compare-panel"><div class="compare-title">Compare</div><div class="compare-items"></div><div class="compare-go"><a href="https://pocketnow.com/compare"><span class="theme-icon-forward"></span>Go</a></div></div> <div class="textwidget custom-html-widget">
</div><script>window.initThunks = window.initThunks ? window.initThunks : [];     (function() {
       var thunk = function() {
         var tag = document.createElement("script");
tag.slug = 'facebook-embed';
tag.priority = '75';
tag.delay = '0';
tag.src = '//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9&appId=701756623345883';
         document.body.appendChild(tag);
         document.body.classList.remove('no-js');
        };
var delay = 0;

var priority = 75;

var slug = "facebook-embed";
        window.initThunks.push({code: thunk, slug: slug, priority: priority, delay: delay});
      })()</script><script>window.initThunks = window.initThunks ? window.initThunks : [];     (function() {
       var thunk = function() {
         var tag = document.createElement("script");
tag.slug = 'facebook-events';
tag.priority = '80';
tag.delay = '0';

var body = document.createTextNode("!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){\n  n.callMethod?\n  n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;\n  n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;\n  t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(\n    window,\n    document,'script','https:\/\/connect.facebook.net\/en_US\/fbevents.js');\nfbq('init', '150243852180055');\nfbq('track', 'PageView');");
tag.appendChild(body);

         document.body.appendChild(tag);
         document.body.classList.remove('no-js');
        };
var delay = 0;

var priority = 80;

var slug = "facebook-events";
        window.initThunks.push({code: thunk, slug: slug, priority: priority, delay: delay});
      })()</script><script>window.initThunks = window.initThunks ? window.initThunks : [];     (function() {
       var thunk = function() {
         var tag = document.createElement("script");
tag.slug = 'twc-addthis-config';
tag.priority = '50';
tag.delay = '0';

var body = document.createTextNode("var addthis_config = { pubid: 'ra-57dcc1bcdbbed33c' };");
tag.appendChild(body);

         document.body.appendChild(tag);
         document.body.classList.remove('no-js');
        };
var delay = 0;

var priority = 50;

var slug = "twc-addthis-config";
        window.initThunks.push({code: thunk, slug: slug, priority: priority, delay: delay});
      })()</script><script>window.initThunks = window.initThunks ? window.initThunks : [];     (function() {
       var thunk = function() {
         var tag = document.createElement("script");
tag.slug = 'twc-addthis-load';
tag.priority = '55';
tag.delay = '0';
tag.onload = function() { addthis.init(); };
tag.src = '//s7.addthis.com/js/300/addthis_widget.js#async=1';
         document.body.appendChild(tag);
         document.body.classList.remove('no-js');
        };
var delay = 0;

var priority = 55;

var slug = "twc-addthis-load";
        window.initThunks.push({code: thunk, slug: slug, priority: priority, delay: delay});
      })()</script><script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var adsforwp_obj = {"ajax_url":"https:\/\/pocketnow.com\/wp-admin\/admin-ajax.php","adsforwp_front_nonce":"3f79261f85","ad_performance_tracker":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/plugins/ads-for-wp/public/assets/js/ads-front.min.js?ver=1.9.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/pocketnow.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.3'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/ui/effect-slide.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/themes/techwise/js/plugins.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/themes/techwise/js/scripts.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/themes/techwise-child/js/mobile-youtube.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-content/themes/techwise-child/js/snippets.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://pocketnow.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script>window.initThunks = window.initThunks ? window.initThunks : [];     (function() {
       var thunk = function() {
         var tag = document.createElement("link");
tag.href = '//fonts.googleapis.com/css?family=Sintony:400,700%7CMerriweather:300,300italic,700,700italic,900&amp;subset=';
tag.type = 'text/css';
tag.rel = 'stylesheet';
         document.body.appendChild(tag);
         document.body.classList.remove('no-js');
        };
var delay = 0;

var priority = 100;

var slug = "link";
        window.initThunks.push({code: thunk, slug: slug, priority: priority, delay: delay});
      })()</script>
<script>
    (function() {
      var loader = function() {
        window.initThunks = window.initThunks ? window.initThunks : [];
        window.initThunks.sort(function(a,b) { return a.priority - b.priority; });
        if(window.initThunks.length == 0) {
          console.log("No initThunks registered");
        }
        function tick() {
          if(window.initThunks.length > 0) {
            var t = window.initThunks.shift();
            if(t.delay > 0) {
              console.log("Delaying thunk: ", t.slug, t.delay);
              setTimeout(function() { 
                console.log("Executing thunk: ", t.slug, t.priority);
                t.code(); 
              }, t.delay);
            } else {
              console.log("Executing thunk: ", t.slug, t.priority);
              t.code();
            }
            tick();
          }
        }
        tick();
      }
      
      if(window.addEventListener) {
        window.addEventListener('load', loader, false);
      } else if(window.attachEvent) {
        window.addEventListener('onload', loader);
      } else {
        loader();
      }
    })();
  </script>

<div id="waldo-tag-2031"></div>
<script type="text/javascript">
        var vglnk = { key: '281465b06f788b33f7ef07ffb311ed68' };

        (function(d, t) {
            var s = d.createElement(t);
            s.type = 'text/javascript';
            s.async = true;
            s.src = '//cdn.viglink.com/api/vglnk.js';
            var r = d.getElementsByTagName(t)[0];
            r.parentNode.insertBefore(s, r);
        }(document, 'script'));
    </script>
</body>
</html>
